aboutsummaryrefslogtreecommitdiffstats
path: root/x11/mlterm
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2008-08-17 09:10:25 +0800
committernobutaka <nobutaka@FreeBSD.org>2008-08-17 09:10:25 +0800
commitb8376d3da93af8a430ba05e19b25188a5f1bc267 (patch)
tree547495716a5c0248756672cd9e25b0364aa0acfa /x11/mlterm
parent0f200c7b7fa6aefca007a3cf282d21321295cd89 (diff)
downloadfreebsd-ports-gnome-b8376d3da93af8a430ba05e19b25188a5f1bc267.tar.gz
freebsd-ports-gnome-b8376d3da93af8a430ba05e19b25188a5f1bc267.tar.zst
freebsd-ports-gnome-b8376d3da93af8a430ba05e19b25188a5f1bc267.zip
- Fix mlterm-menu to handle multibyte characters correctly. [*]
- Respect CFLAGS and LIBS. - Fix build failure of libim-m17nlib when IIIMF support is enabled. PR: ports/126294 [*] Submitted by: Artemiev Igor <ai@kliksys.ru>
Diffstat (limited to 'x11/mlterm')
-rw-r--r--x11/mlterm/Makefile6
-rw-r--r--x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c32
2 files changed, 35 insertions, 3 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 83a51a90e4a4..cb9605d4ceb8 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mlterm
PORTVERSION= 2.9.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,10 +22,11 @@ USE_GNOME= gtk20 lthack
USE_AUTOTOOLS= libtool:15
LIBTOOLFILES= configure kiklib/configure mkf/configure
USE_PERL5_BUILD=yes
+USE_GETTEXT= yes
CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf --enable-utmp \
--with-tools="mlclient,mlconfig,mlterm-menu,mlcc,w3mmlconfig" \
--with-type-engines="xcore,xft"
-CONFIGURE_ENV= LIBS=-L${LOCALBASE}/lib CFLAGS=-I${LOCALBASE}/include
+CONFIGURE_ENV= LIBS="${LIBS} -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/iiim"
OPTIONS= FRIBIDI "Use Fribidi for BiDi rendering" off \
UIM "uim support (experimental)" off \
@@ -68,7 +69,6 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-inputmethod:iiimf:im_iiimf.c
.endif
CONFIGURE_ARGS+= --enable-iiimf
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" CFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/iiim"
LIB_DEPENDS+= iiimcf.3:${PORTSDIR}/textproc/iiimf-client-lib
PLIST_SUB+= IIIMF=""
.else
diff --git a/x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c b/x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c
new file mode 100644
index 000000000000..c316951b594e
--- /dev/null
+++ b/x11/mlterm/files/patch-contrib_tool_mlterm-memu_mlterm-menu.c
@@ -0,0 +1,32 @@
+--- contrib/tool/mlterm-menu/mlterm-menu.c.orig 2008-08-06 08:21:01.000000000 +0400
++++ contrib/tool/mlterm-menu/mlterm-menu.c 2008-08-06 08:30:00.000000000 +0400
+@@ -201,6 +201,7 @@
+ GtkWidget* item;
+ char* pty_list;
+ char* name;
++ gchar *utf8_name;
+ char* pty;
+ char* command;
+ int is_active;
+@@ -228,11 +229,12 @@
+ name = pty;
+ if (strncmp(name, "/dev/", 5) == 0)
+ name += 5;
++ utf8_name = g_locale_to_utf8(name, -1, NULL, NULL, NULL);
+
+ command = malloc(strlen(pty) + 12);
+ sprintf(command, "select_pty=%s", pty);
+
+- item = gtk_radio_menu_item_new_with_label(group, name);
++ item = gtk_radio_menu_item_new_with_label(group, utf8_name);
+ group = gtk_radio_menu_item_group(GTK_RADIO_MENU_ITEM(item));
+
+ gtk_signal_connect(GTK_OBJECT(item), "toggled",
+@@ -240,6 +242,7 @@
+ (gpointer) command);
+
+ gtk_menu_append(menu, item);
++ g_free(utf8_name);
+ if (is_active) {
+ gtk_check_menu_item_set_active(GTK_CHECK_MENU_ITEM(item),
+ TRUE);