aboutsummaryrefslogtreecommitdiffstats
path: root/x11/mrxvt/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-23 13:08:56 +0800
committeredwin <edwin@FreeBSD.org>2004-12-23 13:08:56 +0800
commitf4a7fca16ae9d99a11f71e4b9b6f4015c3f3b710 (patch)
tree9e0a02edc287aecc251f4661f418fbef3484edaf /x11/mrxvt/Makefile
parent869cbb6e22c28a33ddb4a01f250bf10c87f99ea9 (diff)
downloadfreebsd-ports-gnome-f4a7fca16ae9d99a11f71e4b9b6f4015c3f3b710.tar.gz
freebsd-ports-gnome-f4a7fca16ae9d99a11f71e4b9b6f4015c3f3b710.tar.zst
freebsd-ports-gnome-f4a7fca16ae9d99a11f71e4b9b6f4015c3f3b710.zip
new port: x11/mrxvt
Mrxvt (previously named as materm) is a lightweight and powerful multi-tabbed X terminal emulator based on the popular rxvt and aterm. It implements many useful features seen in some modern X terminal emulators, like gnome-terminal and konsole, but keep to be lightweight and independent from the GNOME and KDE desktop environment. The following are the major features of mrxvt (* are new features compared with rxvt, + are enhanced features compared with rxvt): PR: ports/74470 Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'x11/mrxvt/Makefile')
-rw-r--r--x11/mrxvt/Makefile59
1 files changed, 31 insertions, 28 deletions
diff --git a/x11/mrxvt/Makefile b/x11/mrxvt/Makefile
index cac30db984d9..fc3cd12b63d5 100644
--- a/x11/mrxvt/Makefile
+++ b/x11/mrxvt/Makefile
@@ -1,44 +1,47 @@
-# New ports collection makefile for: multi-aterm
-# Date created: 2003-07-11
-# Whom: Sebastian Yepes <esn@x123.info>
+# New ports collection makefile for: mrxvt
+# Date created: 27 Nov 2004
+# Whom: David Yeske <dyeske@yahoo.com>
#
# $FreeBSD$
#
-PORTNAME= multi-aterm
-PORTVERSION= 0.2.1
+PORTNAME= mrxvt
+PORTVERSION= 0.3.9
CATEGORIES= x11
-MASTER_SITES= http://www.nongnu.org/materm/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= materm
-MAINTAINER= esn@x123.info
-COMMENT= A multi terminal based on aterm
+MAINTAINER= dyeske@yahoo.com
+COMMENT= A tabbed version of rxvt
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
-DOCS= AUTHORS ChangeLog INSTALL TODO
-MAN1= multi-aterm.1
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
+ LIBS="${LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib"
-.if defined(WITH_UTMP)
-CONFIGURE_ARGS+= --enable-utmp
-.endif
+MAN1= mrxvt.1
+PLIST_FILES= bin/mrxvt
-.if defined(WITH_WTMP)
-CONFIGURE_ARGS+= --enable-wtmp
-.endif
+PORTDOCS= TIPS README.greek README.menu README.xvt \
+ xdefaults-sample.txt xterm.seq mrxvt.vbs
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You can specify the following options:"
- @${ECHO_MSG} "WITH_UTMP=yes - enable utmp support"
- @${ECHO_MSG} "WITH_WTMP=yes - enable wtmp support"
+.include <bsd.port.pre.mk>
-.if !defined(NOPORTDOCS)
-post-install:
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.if ${OSVERSION} <= 500000
+IGNORE= Does not build
.endif
-.include <bsd.port.mk>
+do-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}/${f}
+.endfor
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/mrxvt ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/doc/mrxvt.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.post.mk>