aboutsummaryrefslogtreecommitdiffstats
path: root/x11/nvidia-driver/files
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2004-08-17 19:54:09 +0800
committerosa <osa@FreeBSD.org>2004-08-17 19:54:09 +0800
commitfe4e9180de2c0858284cbe9c9449153feb123929 (patch)
tree2ffc735d2e8e27255b830ffe88634f12f1a057a8 /x11/nvidia-driver/files
parent5eb3fc278f016c751417de16e196af63fb9e39e0 (diff)
downloadfreebsd-ports-gnome-fe4e9180de2c0858284cbe9c9449153feb123929.tar.gz
freebsd-ports-gnome-fe4e9180de2c0858284cbe9c9449153feb123929.tar.zst
freebsd-ports-gnome-fe4e9180de2c0858284cbe9c9449153feb123929.zip
Update nVidia binary drivers to most recent released version, 6113.
Features: * Support for the latest NVIDIA GPUs including GeForce 6800 Series * Improved interaction with -CURRENT's new threading libraries. It also brings some more general fixes to the port: * Utilizes PORTDOCS * New knobs added * pkg-plist fixed Special note for -CURRENT users: nVidia driver now depends on mem.ko kernel module. Submitted by: Alexey Dokuchaev <danfe@regency.nsu.ru> (maintainer) PR: 70561
Diffstat (limited to 'x11/nvidia-driver/files')
-rw-r--r--x11/nvidia-driver/files/patch-module::Makefile13
-rw-r--r--x11/nvidia-driver/files/patch-src::nvidia_ctl.c15
-rw-r--r--x11/nvidia-driver/files/patch-src::nvidia_dev.c15
-rw-r--r--x11/nvidia-driver/files/patch-src::nvidia_pci.c31
4 files changed, 11 insertions, 63 deletions
diff --git a/x11/nvidia-driver/files/patch-module::Makefile b/x11/nvidia-driver/files/patch-module::Makefile
deleted file mode 100644
index f0c53fb8a471..000000000000
--- a/x11/nvidia-driver/files/patch-module::Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- module/Makefile.orig Wed May 28 23:51:52 2003
-+++ module/Makefile Sun Jan 25 11:47:48 2004
-@@ -14,6 +14,10 @@
- BUILD_DONE= ${.CURDIR}/.build_done
- CLEANFILES+= ${BUILD_DONE}
-
-+.if ${OSVERSION} > 500011
-+KMODDIR?= /boot/modules
-+.endif
-+
- #
- # To enable debugging see nvidia_debug.h
- # uncomment the following line and change the 'debug'
diff --git a/x11/nvidia-driver/files/patch-src::nvidia_ctl.c b/x11/nvidia-driver/files/patch-src::nvidia_ctl.c
deleted file mode 100644
index cf40047c6a03..000000000000
--- a/x11/nvidia-driver/files/patch-src::nvidia_ctl.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/nvidia_ctl.c.old Sun Feb 22 13:05:46 2004
-+++ src/nvidia_ctl.c Sun Feb 22 13:07:25 2004
-@@ -43,7 +43,12 @@
- .d_ioctl = nvidia_ctl_ioctl,
- .d_poll = nvidia_ctl_poll,
- .d_name = "nvidiactl",
-+#if __FreeBSD_version < 502103
- .d_maj = CDEV_MAJOR,
- .d_flags = D_TRACKCLOSE
-+#else
-+ .d_version = D_VERSION,
-+ .d_flags = D_NEEDGIANT|D_TRACKCLOSE
-+#endif
- #endif
- };
diff --git a/x11/nvidia-driver/files/patch-src::nvidia_dev.c b/x11/nvidia-driver/files/patch-src::nvidia_dev.c
deleted file mode 100644
index 0c02c4f8af43..000000000000
--- a/x11/nvidia-driver/files/patch-src::nvidia_dev.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/nvidia_dev.c.old Wed May 28 12:51:52 2003
-+++ src/nvidia_dev.c Sun Feb 22 13:36:25 2004
-@@ -45,7 +45,12 @@
- .d_poll = nvidia_dev_poll,
- .d_mmap = nvidia_dev_mmap,
- .d_name = "nvidia",
-+#if __FreeBSD_version < 502103
- .d_maj = CDEV_MAJOR,
- .d_flags = D_MEM|D_TRACKCLOSE
-+#else
-+ .d_version = D_VERSION,
-+ .d_flags = D_MEM|D_TRACKCLOSE|D_NEEDGIANT
-+#endif
- #endif
- };
diff --git a/x11/nvidia-driver/files/patch-src::nvidia_pci.c b/x11/nvidia-driver/files/patch-src::nvidia_pci.c
index b2e92abdf256..082db9f51d82 100644
--- a/x11/nvidia-driver/files/patch-src::nvidia_pci.c
+++ b/x11/nvidia-driver/files/patch-src::nvidia_pci.c
@@ -1,21 +1,12 @@
---- src/nvidia_pci.c.orig Thu May 29 02:51:52 2003
-+++ src/nvidia_pci.c Fri Oct 3 01:19:55 2003
-@@ -33,6 +33,18 @@
- if (vendor != NVIDIA_VENDORID || device < 0x0020)
- return ENXIO;
+--- src/nvidia_pci.c.orig Mon Aug 16 17:40:56 2004
++++ src/nvidia_pci.c Mon Aug 16 17:41:20 2004
+@@ -218,6 +218,9 @@
+ };
-+ /* Exclude nForce MCP devices from detection */
-+ if (device >= 0x01A4 && device <= 0x01ef)
-+ return ENXIO;
-+
-+ /* Exclude nForce2 MCP2 devices from detection */
-+ if (device >= 0x0060 && device <= 0x006e)
-+ return ENXIO;
-+
-+ /* Exclude nForce3 MCP3 devices from detection */
-+ if (device >= 0x00d4 && device <= 0x00da)
-+ return ENXIO;
-+
- if (rm_get_device_name(device, NV_DEVICE_NAME_LENGTH, name)
- != RM_OK) {
- strcpy(name, "Unknown");
+ DRIVER_MODULE(nvidia, pci, nvidia_pci_driver, nvidia_devclass, nvidia_modevent, 0);
++#if __FreeBSD_version > 502126
++MODULE_DEPEND(nvidia, mem, 1, 1, 1);
++#endif
+
+ #ifdef NV_SUPPORT_OS_AGP
+ MODULE_DEPEND(nvidia, agp, 1, 1, 1);