aboutsummaryrefslogtreecommitdiffstats
path: root/x11/p5-X11-Resolution/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-10-25 10:36:36 +0800
committerwen <wen@FreeBSD.org>2009-10-25 10:36:36 +0800
commited5b258f19e507e07fdcf39c38bef761dc672de6 (patch)
tree4fe672fb4f747a6c2a7fc585ed8a0dc57d345a77 /x11/p5-X11-Resolution/Makefile
parent65a809768371900934929303d5490a4b0df70b6d (diff)
downloadfreebsd-ports-gnome-ed5b258f19e507e07fdcf39c38bef761dc672de6.tar.gz
freebsd-ports-gnome-ed5b258f19e507e07fdcf39c38bef761dc672de6.tar.zst
freebsd-ports-gnome-ed5b258f19e507e07fdcf39c38bef761dc672de6.zip
X11::Resolution provides a method to easily get the resolution
of screens in X11. WWW: http://search.cpan.org/dist/X11-Resolution/ PR: ports/139891 Submitted by: "Zane C.B." <vvelox@vvelox.net> Approved by: mentors(implicit)
Diffstat (limited to 'x11/p5-X11-Resolution/Makefile')
-rw-r--r--x11/p5-X11-Resolution/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11/p5-X11-Resolution/Makefile b/x11/p5-X11-Resolution/Makefile
new file mode 100644
index 000000000000..05bb85159eda
--- /dev/null
+++ b/x11/p5-X11-Resolution/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: x11/p5-X11-Resolution
+# Date created: 2009-10-24 11:30
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= X11-Resolution
+PORTVERSION= 0.0.0
+CATEGORIES= x11 perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Provides a method to get the resolution for a X11 screen
+
+RUN_DEPENDS= ${SITE_PERL}/X11/Protocol.pm:${PORTSDIR}/x11/p5-X11-Protocol
+
+PERL_CONFIGURE= yes
+
+MAN3= X11::Resolution.3
+
+.include <bsd.port.mk>