aboutsummaryrefslogtreecommitdiffstats
path: root/x11/plasma-scriptengine-python
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2010-05-11 23:31:01 +0800
committerfluffy <fluffy@FreeBSD.org>2010-05-11 23:31:01 +0800
commit5ebfcde76687c0b24d9ab841fb266bd7b0e89a0b (patch)
tree1277a966871280555e921519e3a86e4ae5e4da60 /x11/plasma-scriptengine-python
parenta809fcdbde8a07c5f71414a0ed3c8afccf9273f6 (diff)
downloadfreebsd-ports-gnome-5ebfcde76687c0b24d9ab841fb266bd7b0e89a0b.tar.gz
freebsd-ports-gnome-5ebfcde76687c0b24d9ab841fb266bd7b0e89a0b.tar.zst
freebsd-ports-gnome-5ebfcde76687c0b24d9ab841fb266bd7b0e89a0b.zip
- Add plasma-scriptengines to the build
With hat on: kde@
Diffstat (limited to 'x11/plasma-scriptengine-python')
-rw-r--r--x11/plasma-scriptengine-python/Makefile34
-rw-r--r--x11/plasma-scriptengine-python/files/patch-plasma__generic__scriptengines__python__CMakeLists.txt11
-rw-r--r--x11/plasma-scriptengine-python/pkg-descr3
-rw-r--r--x11/plasma-scriptengine-python/pkg-plist20
4 files changed, 68 insertions, 0 deletions
diff --git a/x11/plasma-scriptengine-python/Makefile b/x11/plasma-scriptengine-python/Makefile
new file mode 100644
index 000000000000..11152e74c6d2
--- /dev/null
+++ b/x11/plasma-scriptengine-python/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: plasma-scriptengine-python
+# Date created: 2010-03-14
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plasma-scriptengine-python
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= x11 kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DISTNAME= kdebase-workspace-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Plasma scriptengine for Python
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= kdeprefix kdelibs automoc4 pykde4
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build uic_build rcc_build
+USE_PYTHON= 2.5+
+MD5_FILE= ${PORTSDIR}/x11/kdebase4-workspace/distinfo
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/plasma/generic/scriptengines/python
+CMAKE_OUTSOURCE= yes
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,$${PYTHON_SITE_PACKAGES_DIR},${PYTHONPREFIX_SITELIBDIR},g' \
+ ${CMAKE_SOURCE_PATH}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/x11/plasma-scriptengine-python/files/patch-plasma__generic__scriptengines__python__CMakeLists.txt b/x11/plasma-scriptengine-python/files/patch-plasma__generic__scriptengines__python__CMakeLists.txt
new file mode 100644
index 000000000000..5f9b6ffdbfdd
--- /dev/null
+++ b/x11/plasma-scriptengine-python/files/patch-plasma__generic__scriptengines__python__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./plasma/generic/scriptengines/python/CMakeLists.txt.orig 2009-11-13 13:57:51.000000000 +0300
++++ ./plasma/generic/scriptengines/python/CMakeLists.txt 2010-03-14 01:48:21.780880917 +0300
+@@ -1,5 +1,8 @@
+ project(plasma-python)
+
++find_package(KDE4 4.4.1 REQUIRED)
++macro_optional_find_package(PythonLibrary)
++
+ INCLUDE(PythonMacros)
+
+ # install the library, .desktop, and plasma.py
diff --git a/x11/plasma-scriptengine-python/pkg-descr b/x11/plasma-scriptengine-python/pkg-descr
new file mode 100644
index 000000000000..088bb553eb0b
--- /dev/null
+++ b/x11/plasma-scriptengine-python/pkg-descr
@@ -0,0 +1,3 @@
+Plasma scriptengine for Python.
+
+WWW: http://www.kde.org/
diff --git a/x11/plasma-scriptengine-python/pkg-plist b/x11/plasma-scriptengine-python/pkg-plist
new file mode 100644
index 000000000000..187711287635
--- /dev/null
+++ b/x11/plasma-scriptengine-python/pkg-plist
@@ -0,0 +1,20 @@
+%%PYTHON_SITELIBDIR%%/PyKDE4/plasmascript.py
+%%PYTHON_SITELIBDIR%%/PyKDE4/plasmascript.pyc
+share/apps/plasma_scriptengine_python/plasma_importer.py
+share/apps/plasma_scriptengine_python/plasma_importer.pyc
+share/apps/plasma_scriptengine_python/pyappletscript.py
+share/apps/plasma_scriptengine_python/pyappletscript.pyc
+share/apps/plasma_scriptengine_python/pydataengine.py
+share/apps/plasma_scriptengine_python/pydataengine.pyc
+share/apps/plasma_scriptengine_python/pyrunner.py
+share/apps/plasma_scriptengine_python/pyrunner.pyc
+share/apps/plasma_scriptengine_python/pywallpaper.py
+share/apps/plasma_scriptengine_python/pywallpaper.pyc
+share/kde4/services/plasma-scriptengine-applet-python.desktop
+share/kde4/services/plasma-scriptengine-dataengine-python.desktop
+share/kde4/services/plasma-scriptengine-runner-python.desktop
+share/kde4/services/plasma-scriptengine-wallpaper-python.desktop
+@dirrm share/apps/plasma_scriptengine_python
+@dirrmtry %%PYTHON_SITELIBDIR%%/PyKDE4
+@dirrmtry %%PYTHON_SITELIBDIR%%
+@dirrmtry %%PYTHON_LIBDIR%%