aboutsummaryrefslogtreecommitdiffstats
path: root/x11/qt4-graphicssystems-opengl
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
committermakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
commit1b9ec1582fbf2b219f611d52fca8410e3cd06973 (patch)
tree42a169743be676e050a1e903ddf771488b5da9bb /x11/qt4-graphicssystems-opengl
parent69e87da3a0f46ad0c31d376913c821cc72c51ecd (diff)
downloadfreebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.gz
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.zst
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.zip
KDE FreeBSD team is glad to present Qt 4.7.1 in ports.
Along with Qt4 the following ports are updated: PyQt4 ports to 4.8.1 devel/py-sip to 4.11.2 devel/qscintilla2 to 2.4.5 PyKDE3 to 3.16.7 PyQt3 tp 3.18.2-snapshot-20091119 New ports added: devel/qt4-declarative devel/py-qt4-declarative x11/qt4-graphicssystems-opengl This release has been contributed by: Thomas Abthorpe (tabthorpe) Max Brazhnikov (makc) Dima Panov (fluffy) Alberto Villa (avilla) We'd like to thank Martin Wilke (miwi) for exp-run.
Diffstat (limited to 'x11/qt4-graphicssystems-opengl')
-rw-r--r--x11/qt4-graphicssystems-opengl/Makefile53
-rw-r--r--x11/qt4-graphicssystems-opengl/pkg-descr11
-rw-r--r--x11/qt4-graphicssystems-opengl/pkg-plist4
3 files changed, 68 insertions, 0 deletions
diff --git a/x11/qt4-graphicssystems-opengl/Makefile b/x11/qt4-graphicssystems-opengl/Makefile
new file mode 100644
index 000000000000..025f56393b59
--- /dev/null
+++ b/x11/qt4-graphicssystems-opengl/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: qt4-graphicssystems-opengl
+# Date created: 2010-11-07
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graphicssystems
+DISTVERSION= ${QT4_VERSION}
+CATEGORIES?= x11
+PKGNAMEPREFIX= qt4-
+PKGNAMESUFFIX= -opengl
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= OpenGL rendering engine (experimental)
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build opengl
+QT_NONSTANDARD= yes
+QT_DIST= yes
+MAKE_JOBS_SAFE= yes
+
+HAS_CONFIGURE= yes
+USE_GL= glu
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
+ PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
+ src/activeqt src/dbus src/multimedia src/network src/openvg \
+ src/phonon src/qt3support src/s60installs src/s60main \
+ src/script src/scripttools src/sql src/svg src/testlib \
+ src/tools src/winmain src/xml src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}/opengl
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+
+.include <bsd.port.mk>
diff --git a/x11/qt4-graphicssystems-opengl/pkg-descr b/x11/qt4-graphicssystems-opengl/pkg-descr
new file mode 100644
index 000000000000..a319375a7bb9
--- /dev/null
+++ b/x11/qt4-graphicssystems-opengl/pkg-descr
@@ -0,0 +1,11 @@
+Qt provides a platform-independent API to all central platform
+functionality: GUI, database access, networking, file handling,
+etc.
+
+This port provides OpenGL graphics backend, which is used for
+on-screen widgets and QPixmaps. See for details:
+
+http://doc.qt.nokia.com/4.7/qapplication.html#setGraphicsSystem
+http://labs.qt.nokia.com/2008/10/22/so-long-and-thanks-for-the-blit/
+
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/x11/qt4-graphicssystems-opengl/pkg-plist b/x11/qt4-graphicssystems-opengl/pkg-plist
new file mode 100644
index 000000000000..b62b95506eaf
--- /dev/null
+++ b/x11/qt4-graphicssystems-opengl/pkg-plist
@@ -0,0 +1,4 @@
+%%QT_PLUGINDIR_REL%%/graphicssystems/libqglgraphicssystem.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/graphicssystems/libqglgraphicssystem.so.debug
+@dirrmtry %%QT_PLUGINDIR_REL%%/graphicssystems
+@dirrmtry %%QT_PLUGINDIR_REL%%