aboutsummaryrefslogtreecommitdiffstats
path: root/x11/rxvt-unicode
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2012-08-26 20:03:29 +0800
committerthierry <thierry@FreeBSD.org>2012-08-26 20:03:29 +0800
commitcc4a7cdb94aabaeb2a5cc64aac0b1fececa31d97 (patch)
tree058b87c084423e2e49e8152998ccffe79bcd83d5 /x11/rxvt-unicode
parentb7388cba33be64a02f2433583ffaca030a695028 (diff)
downloadfreebsd-ports-gnome-cc4a7cdb94aabaeb2a5cc64aac0b1fececa31d97.tar.gz
freebsd-ports-gnome-cc4a7cdb94aabaeb2a5cc64aac0b1fececa31d97.tar.zst
freebsd-ports-gnome-cc4a7cdb94aabaeb2a5cc64aac0b1fececa31d97.zip
1) Fix build on recent current and 9-STABLE.
2) Add an option to depend (or not) on freedesktop startup notification. PR: ports/170645 (1) and ports/170667 (2) Submitted by: Mykola Dzham <i (at) levsha.me> (1) and Konstantinos Koukopoulos <koukopoulos (at) gmail.com> (2)
Diffstat (limited to 'x11/rxvt-unicode')
-rw-r--r--x11/rxvt-unicode/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 30e0926b0316..e70cd0524a27 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rxvt-unicode
PORTVERSION= 9.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
@@ -26,7 +26,7 @@ USE_GNOME= pkgconfig
USE_XORG= xpm xft xrender
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LIBS="-lutil"
+CONFIGURE_ENV= LIBS="-lstdc++ -lutil"
CONFIGURE_ARGS= --enable-everything --with-term=rxvt \
--with-terminfo=${LOCALBASE}/share/misc/terminfo.db
USE_BZIP2= yes
@@ -48,6 +48,7 @@ OPTIONS= \
IMLOCALE_FIX "imlocale encoding conversion fix" On \
GDK_PIXBUF "Use gdk-pixbuf for background images" On \
AFTERIMAGE "Use libAfterImage for background images" Off \
+ NOTIFY "Freedesktop startup notification support" Off \
256_COLOR "Support for 256 colors" Off
.include <bsd.port.pre.mk>
@@ -139,7 +140,7 @@ CONFIGURE_ARGS+= --disable-pixbuf
. if defined(WITHOUT_AFTERIMAGE)
CONFIGURE_ARGS+= --disable-afterimage # To be upgraded
. else
-LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
+LIB_DEPENDS+= AfterImage:${PORTSDIR}/graphics/libafterimage
CONFIGURE_ARGS+= --enable-afterimage
. endif
.else
@@ -147,6 +148,14 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+= --enable-pixbuf
.endif
+# enable startup notification
+.if defined(WITHOUT_NOTIFY)
+CONFIGURE_ARGS+= --disable-startup-notification
+.else
+CONFIGURE_ARGS+= --enable-startup-notification
+LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
+.endif
+
# enable support for 256 colors
.if defined(WITH_256_COLOR)
CONFIGURE_ARGS+= --enable-256-color