aboutsummaryrefslogtreecommitdiffstats
path: root/x11/stalonetray
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-02-12 22:20:32 +0800
committermiwi <miwi@FreeBSD.org>2010-02-12 22:20:32 +0800
commitbd3eed898b037c62b5e780eb6870a1593b2b5373 (patch)
tree32daaa186403fcc477e05e1eaf6d3ada7028673d /x11/stalonetray
parent8af982196d85c15c8b206f0f85c981daf360da64 (diff)
downloadfreebsd-ports-gnome-bd3eed898b037c62b5e780eb6870a1593b2b5373.tar.gz
freebsd-ports-gnome-bd3eed898b037c62b5e780eb6870a1593b2b5373.tar.zst
freebsd-ports-gnome-bd3eed898b037c62b5e780eb6870a1593b2b5373.zip
- Update to 0.8.0
PR: 143818 Submitted by: Ports Fury
Diffstat (limited to 'x11/stalonetray')
-rw-r--r--x11/stalonetray/Makefile3
-rw-r--r--x11/stalonetray/distinfo6
-rw-r--r--x11/stalonetray/files/patch-src__main.c16
3 files changed, 20 insertions, 5 deletions
diff --git a/x11/stalonetray/Makefile b/x11/stalonetray/Makefile
index dcc31438c594..59f925694275 100644
--- a/x11/stalonetray/Makefile
+++ b/x11/stalonetray/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stalonetray
-PORTVERSION= 0.7.6
+PORTVERSION= 0.8.0
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -15,7 +15,6 @@ COMMENT= STAnd-aLONE system tray
USE_BZIP2= yes
USE_XORG= xpm
-USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-native-kde \
--disable-debug
diff --git a/x11/stalonetray/distinfo b/x11/stalonetray/distinfo
index 65a7193c1520..87e11abaa9e7 100644
--- a/x11/stalonetray/distinfo
+++ b/x11/stalonetray/distinfo
@@ -1,3 +1,3 @@
-MD5 (stalonetray-0.7.6.tar.bz2) = eebb46182b64d75b89776bbfc867f470
-SHA256 (stalonetray-0.7.6.tar.bz2) = 35043df77437b66ade4a07b69f31aaa8c157ddc2833899eeb8a4794399a9e061
-SIZE (stalonetray-0.7.6.tar.bz2) = 133973
+MD5 (stalonetray-0.8.0.tar.bz2) = b2ce0d8044f7dc76ac9971def1faab37
+SHA256 (stalonetray-0.8.0.tar.bz2) = 6a561117b6de83c708d3773c98d9546e2227d9dbe404dabbd196c6aa6fa59431
+SIZE (stalonetray-0.8.0.tar.bz2) = 147004
diff --git a/x11/stalonetray/files/patch-src__main.c b/x11/stalonetray/files/patch-src__main.c
new file mode 100644
index 000000000000..6e7a13fbbfc6
--- /dev/null
+++ b/x11/stalonetray/files/patch-src__main.c
@@ -0,0 +1,16 @@
+--- src/main.c.orig 2009-10-21 23:07:11.000000000 +0900
++++ src/main.c 2010-01-21 01:15:42.000000000 +0900
+@@ -323,9 +323,13 @@
+ #endif
+ /* React on WM (re)starts */
+ if (ev.atom == XInternAtom(tray_data.dpy, _NET_SUPPORTING_WM_CHECK, False)) {
++#ifdef DEBUG
+ ewmh_list_supported_atoms(tray_data.dpy);
++#endif
+ tray_set_wm_hints();
++#ifndef NO_NATIVE_KDE
+ kde_tray_update_fallback_mode(tray_data.dpy);
++#endif
+ }
+ /* React on _XEMBED_INFO changes of embedded icons
+ * (currently used to track icon visibility status) */