aboutsummaryrefslogtreecommitdiffstats
path: root/x11/tint-devel
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2015-04-02 20:25:06 +0800
committerxmj <xmj@FreeBSD.org>2015-04-02 20:25:06 +0800
commit9e233dd28f63ed9f167abd4f324fc30457202f78 (patch)
tree053e1661dbb8da0f69a599ab4c10c3721d7774cf /x11/tint-devel
parentedf256e4ff90508be1be5596dc1dc402f2427e53 (diff)
downloadfreebsd-ports-gnome-9e233dd28f63ed9f167abd4f324fc30457202f78.tar.gz
freebsd-ports-gnome-9e233dd28f63ed9f167abd4f324fc30457202f78.tar.zst
freebsd-ports-gnome-9e233dd28f63ed9f167abd4f324fc30457202f78.zip
x11/tint-devel: add port
Tint is a simple panel/taskbar/systray intentionally made for openbox3, but should also work with other window managers. The goal is to keep a clean and unintrusive look with lightweight code and compliance with freedesktop specifications. Tint taskbar features * color/transparency on font, icon, border and background * customize mouse event * drag and drop task between desktop and switch desktop Tint panel features * clock with font, color and transparency * multi-monitor : panel position adjust to monitor, taskbar by monitor This is the development version. It has some cool new features, but also may have some bugs. WWW: http://code.google.com/p/tint2/ PR: 198317 Differential Revision: https://reviews.freebsd.org/D2180 Submitted by: Yamagi@yamagi.org Approved by: koobs (mentor)
Diffstat (limited to 'x11/tint-devel')
-rw-r--r--x11/tint-devel/Makefile75
-rw-r--r--x11/tint-devel/distinfo2
-rw-r--r--x11/tint-devel/pkg-descr18
-rw-r--r--x11/tint-devel/pkg-plist6
4 files changed, 101 insertions, 0 deletions
diff --git a/x11/tint-devel/Makefile b/x11/tint-devel/Makefile
new file mode 100644
index 000000000000..9aca2af4308f
--- /dev/null
+++ b/x11/tint-devel/Makefile
@@ -0,0 +1,75 @@
+# $FreeBSD$
+
+PORTNAME= tint2
+PORTVERSION= 2.00.${SVNREVISION:C/r//}
+CATEGORIES= x11
+MASTER_SITES= http://deponie.yamagi.org/freebsd/distfiles/tint/
+PKGNAMESUFFIX= -devel
+DISTNAME= tint2-devel-${SVNREVISION}
+
+MAINTAINER= yamagi@yamagi.org
+COMMENT= Lightweight freedesktop-compliant panel (development version)
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2 \
+ librsvg-2.so:${PORTSDIR}/graphics/librsvg2
+
+CONFLICTS= tint2-[0-9]*
+
+USES= alias cmake pkgconfig tar:xz
+USE_GNOME= glib20 pango
+USE_XORG= xcomposite xdamage xinerama xrandr
+
+CMAKE_ARGS= -DENABLE_BATTERY:BOOL=ON -DMANDIR:PATH=man
+
+OPTIONS_DEFINE= DOCS EXAMPLES PYCONF
+OPTIONS_DEFAULT= PYCONF
+OPTIONS_SUB= yes
+PYCONF_DESC= Configuration editing tool (requires python)
+
+SVNREVISION= r727
+
+PORTEXAMPLES= icon_and_text_1.tint2rc icon_and_text_2.tint2rc \
+ icon_and_text_3.tint2rc icon_and_text_4.tint2rc \
+ icon_only_1.tint2rc icon_only_2.tint2rc icon_only_3.tint2rc \
+ icon_only_4.tint2rc icon_only_6.tint2rc icon_only_7.tint2rc \
+ text_only_1.tint2rc text_only_2.tint2rc text_only_3.tint2rc \
+ text_only_4.tint2rc text_only_5.tint2rc text_only_6.tint2rc tint2rc
+PORTDOCS= AUTHORS ChangeLog README
+
+PYCONF_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
+PYCONF_USES= python
+PYCONF_USE= gnome=gtk20,pygtk2
+PYCONF_CMAKE_ON= -DENABLE_TINT2CONF:BOOL=ON
+PYCONF_CMAKE_OFF= -DENABLE_TINT2CONF:BOOL=OFF
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPYCONF}
+PYCONF_SRC= ${WRKSRC}/src/tint2conf
+
+post-patch:
+ @${MV} ${PYCONF_SRC}/tintwizard.py ${PYCONF_SRC}/tintwizard.py.Dist
+ @${SED} -e 's#pidof#pgrep#g' ${PYCONF_SRC}/tintwizard.py.Dist \
+ > ${PYCONF_SRC}/tintwizard.py
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tint2 ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/tint2-devel
+ ${INSTALL_DATA} ${WRKSRC}/default_icon.png ${STAGEDIR}${PREFIX}/share/tint2-devel
+ ${INSTALL_MAN} ${WRKSRC}/doc/tint2.1 ${STAGEDIR}${MANPREFIX}/man/man1
+.if ${PORT_OPTIONS:MPYCONF}
+ ${INSTALL_PROGRAM} ${PYCONF_SRC}/tint2conf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${PYCONF_SRC}/tintwizard.py ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${PYCONF_SRC}/tint2conf.desktop ${STAGEDIR}${PREFIX}/share/applications
+.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/sample/|} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/tint-devel/distinfo b/x11/tint-devel/distinfo
new file mode 100644
index 000000000000..4e4684d2ab2b
--- /dev/null
+++ b/x11/tint-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tint2-devel-r727.tar.xz) = 7e2e3d234af3b5a1b34d44e087cc6377acb6b93765114d91c11308b51b14f73a
+SIZE (tint2-devel-r727.tar.xz) = 120604
diff --git a/x11/tint-devel/pkg-descr b/x11/tint-devel/pkg-descr
new file mode 100644
index 000000000000..bc8772c2deb7
--- /dev/null
+++ b/x11/tint-devel/pkg-descr
@@ -0,0 +1,18 @@
+Tint is a simple panel/taskbar/systray intentionally made for openbox3,
+but should also work with other window managers. The goal is to keep a
+clean and unintrusive look with lightweight code and compliance with
+freedesktop specifications.
+
+Tint taskbar features
+ * color/transparency on font, icon, border and background
+ * customize mouse event
+ * drag and drop task between desktop and switch desktop
+
+Tint panel features
+ * clock with font, color and transparency
+ * multi-monitor : panel position adjust to monitor, taskbar by monitor
+
+This is the development version. It has some cool new features, but also
+may have some bugs.
+
+WWW: http://code.google.com/p/tint2/
diff --git a/x11/tint-devel/pkg-plist b/x11/tint-devel/pkg-plist
new file mode 100644
index 000000000000..a2c87dccfb4a
--- /dev/null
+++ b/x11/tint-devel/pkg-plist
@@ -0,0 +1,6 @@
+bin/tint2
+man/man1/tint2.1.gz
+%%PYCONF%%bin/tint2conf
+%%PYCONF%%bin/tintwizard.py
+%%PYCONF%%share/applications/tint2conf.desktop
+%%DATADIR%%-devel/default_icon.png