aboutsummaryrefslogtreecommitdiffstats
path: root/x11/tint
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2008-07-22 03:07:41 +0800
committerdougb <dougb@FreeBSD.org>2008-07-22 03:07:41 +0800
commitfa158f66136d4fefc99c24cc86dc971754932989 (patch)
treeca0935194dbe7229276125234f4cb8b45d99addd /x11/tint
parentbf6d735b1adf47461c36a955497bd958aa5363b1 (diff)
downloadfreebsd-ports-gnome-fa158f66136d4fefc99c24cc86dc971754932989.tar.gz
freebsd-ports-gnome-fa158f66136d4fefc99c24cc86dc971754932989.tar.zst
freebsd-ports-gnome-fa158f66136d4fefc99c24cc86dc971754932989.zip
Tint is a simple panel/taskbar intentionally made for openbox3, but should
also work with other window managers. The goal is to keep a clean and unintrusive look with lightweight code and compliance with freedesktop specifications. Tint taskbar features * color/transparency on font, icon, border and background * customize mouse event * drag and drop task between desktop and switch desktop Tint panel features * clock with font, color and transparency * multi-monitor : panel position adjust to monitor, taskbar by monitor WWW: http://code.google.com/p/tint2/
Diffstat (limited to 'x11/tint')
-rw-r--r--x11/tint/Makefile57
-rw-r--r--x11/tint/distinfo3
-rw-r--r--x11/tint/pkg-descr19
3 files changed, 79 insertions, 0 deletions
diff --git a/x11/tint/Makefile b/x11/tint/Makefile
new file mode 100644
index 000000000000..556c936c1a60
--- /dev/null
+++ b/x11/tint/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: tint
+# Date created: 21 July 2008
+# Whom: dougb@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tint
+PORTVERSION= 0.6.0
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT= Lightweight freedesktop-compliant panel/taskbar/clock
+
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+
+PROJECTHOST= tint2
+USE_GNOME= pango
+USE_XORG= xinerama
+USE_EFL= imlib2
+USE_GMAKE= yes
+
+MAKE_ENV+= DESTDIR=${PREFIX}
+
+PLIST_FILES= bin/tint \
+ etc/xdg/tint/tintrc
+PLIST_DIRS= etc/xdg/tint
+
+PORTDOCS= ChangeLog README tint-0.6.pdf
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+ALL_TARGET= ${PORTNAME}
+
+post-patch:
+ @${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.dist
+ @${SED} -e 's#/usr/bin#/bin#g' \
+ ${WRKSRC}/Makefile.dist > ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../ChangeLog ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../doc/tint-0.6.pdf ${DOCSDIR}
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../tintrc* ${EXAMPLESDIR}
+.for N in 1 2 3 4
+PLIST_FILES+= ${EXAMPLESDIR_REL}/tintrc${N}
+.endfor
+PLIST_DIRS+= ${EXAMPLESDIR_REL}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/tint/distinfo b/x11/tint/distinfo
new file mode 100644
index 000000000000..c5465d6d718d
--- /dev/null
+++ b/x11/tint/distinfo
@@ -0,0 +1,3 @@
+MD5 (tint-0.6.0.tar.gz) = 50a327730429373a18286b27f915fefd
+SHA256 (tint-0.6.0.tar.gz) = d762311e4bda14ea49f306cb7df1b8375926a4279a48f46ee46a6b86ac2a3603
+SIZE (tint-0.6.0.tar.gz) = 362794
diff --git a/x11/tint/pkg-descr b/x11/tint/pkg-descr
new file mode 100644
index 000000000000..6b75b7d317e3
--- /dev/null
+++ b/x11/tint/pkg-descr
@@ -0,0 +1,19 @@
+Tint is a simple panel/taskbar intentionally made for openbox3, but should
+also work with other window managers.
+
+The goal is to keep a clean and unintrusive look with lightweight code and
+compliance with freedesktop specifications.
+
+Tint taskbar features
+ * color/transparency on font, icon, border and background
+ * customize mouse event
+ * drag and drop task between desktop and switch desktop
+
+Tint panel features
+ * clock with font, color and transparency
+ * multi-monitor : panel position adjust to monitor, taskbar by monitor
+
+WWW: http://code.google.com/p/tint2/
+
+- Doug Barton
+dougb@FreeBSD.org