aboutsummaryrefslogtreecommitdiffstats
path: root/x11/tkXwin
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-01-09 16:49:35 +0800
committergahr <gahr@FreeBSD.org>2014-01-09 16:49:35 +0800
commit0c1410e73f504eb6b00822824ad1cf742fbad32d (patch)
tree260c1d1e2a9c8db5c6a9ce37e8c98437f49c985e /x11/tkXwin
parentc3530af4bcc91bb4453b22382cb0d57909b567cd (diff)
downloadfreebsd-ports-gnome-0c1410e73f504eb6b00822824ad1cf742fbad32d.tar.gz
freebsd-ports-gnome-0c1410e73f504eb6b00822824ad1cf742fbad32d.tar.zst
freebsd-ports-gnome-0c1410e73f504eb6b00822824ad1cf742fbad32d.zip
- Convert to USES=tk
- STAGE-clean - PREFIX-clean MFH: 2014Q1
Diffstat (limited to 'x11/tkXwin')
-rw-r--r--x11/tkXwin/Makefile6
-rw-r--r--x11/tkXwin/files/patch-Makefile.in23
-rw-r--r--x11/tkXwin/files/patch-configure6
3 files changed, 27 insertions, 8 deletions
diff --git a/x11/tkXwin/Makefile b/x11/tkXwin/Makefile
index d5a9d03d4749..447230ded680 100644
--- a/x11/tkXwin/Makefile
+++ b/x11/tkXwin/Makefile
@@ -11,16 +11,16 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dsh@vlink.ru
COMMENT= Tcl/Tk library to detect idle periods of an X session
+USES= tk:84
GNU_CONFIGURE= yes
USE_XORG= xt xscrnsaver
USE_LDCONFIG= yes
-USE_TK= 84+
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-tcl=${TCL_LIBDIR} \
--with-tclinclude=${TCL_INCLUDEDIR} \
--with-tk=${TK_LIBDIR} \
--with-tkinclude=${TK_INCLUDEDIR}
CONFIGURE_ENV= INSTALL="${INSTALL_DATA}"
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11/tkXwin/files/patch-Makefile.in b/x11/tkXwin/files/patch-Makefile.in
index bdc7fb69ebef..6a7f61b86768 100644
--- a/x11/tkXwin/files/patch-Makefile.in
+++ b/x11/tkXwin/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sun Aug 25 10:29:52 2002
-+++ Makefile.in Tue Aug 9 15:09:49 2005
+--- Makefile.in.orig 2002-08-25 08:29:52.000000000 +0200
++++ Makefile.in 2014-01-09 09:33:06.000000000 +0100
@@ -14,8 +14,8 @@
#
@@ -20,3 +20,22 @@
common_sources = tkXwin.c
+@@ -432,14 +432,14 @@
+
+
+ install-exec-hook:
+- $(mkinstalldirs) @PKG_TCL@
++ $(mkinstalldirs) $(DESTDIR)@PKG_TCL@
+ echo "package ifneeded tkXwin" \
+ `echo $(VERSION) | awk -F. '{ printf "%s.%s", $$1, $$2 }'` \
+- "[list load $(DESTDIR)$(libdir)/libtkXwin.so]" \
+- > @PKG_TCL@/pkgIndex.tcl
++ "[list load $(libdir)/libtkXwin.so]" \
++ > $(DESTDIR)@PKG_TCL@/pkgIndex.tcl
+ sed -e 's%load .libs/libtkXwin.so%package require tkXwin%' \
+ < test.tcl \
+- > @PKG_TCL@/test.tcl
++ > $(DESTDIR)@PKG_TCL@/test.tcl
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/x11/tkXwin/files/patch-configure b/x11/tkXwin/files/patch-configure
index 824fd4a21489..92498d01c824 100644
--- a/x11/tkXwin/files/patch-configure
+++ b/x11/tkXwin/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2002-08-25 10:29:53.000000000 +0400
-+++ configure 2007-10-14 20:44:46.000000000 +0400
+--- configure.orig 2002-08-25 08:29:53.000000000 +0200
++++ configure 2014-01-09 09:46:12.000000000 +0100
@@ -1798,7 +1798,7 @@
AS="$AS" DLLTOOL="$DLLTOOL" OBJDUMP="$OBJDUMP" \
objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
@@ -14,7 +14,7 @@
-PKG_TCL=${TCL_PACKAGE_PATH}/tkXwin
-+PKG_TCL=${TCL_PREFIX}/lib/tkXwin
++PKG_TCL=$prefix/lib/tkXwin