aboutsummaryrefslogtreecommitdiffstats
path: root/x11/workrave
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-03-28 09:50:20 +0800
committermezz <mezz@FreeBSD.org>2008-03-28 09:50:20 +0800
commite0d22c473b9ab74f8ce18fa0d8a6df08b94d9057 (patch)
tree21cc745dff1460c8e5f4f15009065e1accbd7f41 /x11/workrave
parent4c09027fe62f992958ead2c844c97a0b3279b924 (diff)
downloadfreebsd-ports-gnome-e0d22c473b9ab74f8ce18fa0d8a6df08b94d9057.tar.gz
freebsd-ports-gnome-e0d22c473b9ab74f8ce18fa0d8a6df08b94d9057.tar.zst
freebsd-ports-gnome-e0d22c473b9ab74f8ce18fa0d8a6df08b94d9057.zip
Fix the build with new libsigc++20 2.2.2. I have tested these ports in runtime
and these seem work fine in normal use. I don't test every functions, so let me know if you have any problem with it. Reported by: pointyhat via pav
Diffstat (limited to 'x11/workrave')
-rw-r--r--x11/workrave/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 205ecb72b172..de799d989870 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -50,4 +50,15 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|#include <sigc++\/compatibility\.h>||g ; \
+ s|SigC::Signal|sigc::signal|g ; \
+ s|SigC::slot_class|sigc::mem_fun|g ; \
+ s|SigC::Connection|sigc::connection|g ; \
+ s|SigC::Slot|sigc::slot|g ; \
+ s|SigC::Object|sigc::trackable|g ; \
+ s|SigC::slot|sigc::mem_fun|g' \
+ ${WRKSRC}/frontend/gtkmm/src/*.* \
+ ${WRKSRC}/frontend/plugin/*/gtkmm/src/*.*
+
.include <bsd.port.post.mk>