aboutsummaryrefslogtreecommitdiffstats
path: root/x11/workrave
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-06-19 17:33:03 +0800
committersat <sat@FreeBSD.org>2007-06-19 17:33:03 +0800
commitf9a4475e5d721b03cf004a662125d349aee386cc (patch)
tree1d50c405705ef0e2c09888def4b1d97dc9246f51 /x11/workrave
parent57a9a1f986655c4cc1460538b4609e375eaaef89 (diff)
downloadfreebsd-ports-gnome-f9a4475e5d721b03cf004a662125d349aee386cc.tar.gz
freebsd-ports-gnome-f9a4475e5d721b03cf004a662125d349aee386cc.tar.zst
freebsd-ports-gnome-f9a4475e5d721b03cf004a662125d349aee386cc.zip
- Relax gcc version requirement from 3.4 to 3.4+ to allow build on 7.x
- Minor tweaks while I'm here Reported by: pointyhat via kris
Diffstat (limited to 'x11/workrave')
-rw-r--r--x11/workrave/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 1ceea6168a3e..376e3c949ef4 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -23,17 +23,15 @@ LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
LIB_DEPENDS+= gnet-2.0.0:${PORTSDIR}/net/gnet2
.endif
-USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 intltool
.if !defined(WITHOUT_GNOME)
USE_GNOME+= gnomepanel
.endif
-USE_GCC= 3.4
+USE_GCC= 3.4+
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-gconf
.if defined(WITHOUT_GNOME)
CONFIGURE_ARGS+=--disable-gnome