aboutsummaryrefslogtreecommitdiffstats
path: root/x11/x3270/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-16 17:07:41 +0800
committeredwin <edwin@FreeBSD.org>2004-12-16 17:07:41 +0800
commitb1ebd805e1fcde7a4f5732e247659a942c64e0c0 (patch)
treeda9458e160902e6ac427441342c818313e12285a /x11/x3270/Makefile
parent5220fd64430f9670fa7e34cddd96634182b69064 (diff)
downloadfreebsd-ports-gnome-b1ebd805e1fcde7a4f5732e247659a942c64e0c0.tar.gz
freebsd-ports-gnome-b1ebd805e1fcde7a4f5732e247659a942c64e0c0.tar.zst
freebsd-ports-gnome-b1ebd805e1fcde7a4f5732e247659a942c64e0c0.zip
Update port: x11/x3270 to version 3.3.2p1
This port has been stuck on an ancient, non-SSL-capable version for seveal years. Please consider updating to a more recent upstream source. The attached files are offered as a starting point; some "adjustment" is probably needed. Note that what's below completely replaces the previous port; all previous patches are no longer valid. Also, I've added "net" to the CATEGORIES, along with a link to the official web page in the package description. The compilation produces one "warning: assignment from incompatible pointer type"; this deserves further investigation (particularly for 64-bit builds). Since I do not have access to the requisite legacy systems, I am unable to properly test this software (particularly the SSL aspects). PR: ports/70808 Submitted by: Eric P. Scott <eps+psub0408@ana.com> Approved by: maintainer timeout
Diffstat (limited to 'x11/x3270/Makefile')
-rw-r--r--x11/x3270/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 7a9007715d04..61f45afce783 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -6,23 +6,30 @@
#
PORTNAME= x3270
-PORTVERSION= 3.1.1.6
-CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= applications
+PORTVERSION= 3.3.2p1
+CATEGORIES= x11 net
+MASTER_SITES= http://x3270.bgp.nu/download/
+EXTRACT_SUFX= .tgz
+DISTFILES= ${PORTNAME}-332p1${EXTRACT_SUFX}
-MAINTAINER= onatan@gmail.com
+MAINTAINER= Yonatan@xpert.com
COMMENT= 3270 Terminal emulator
BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
USE_IMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --without-pr3287 --with-fontdir=local --disable-dbcs
+.if defined(WITHOUT_OPENSSL)
+CONFIGURE_ARGS+= --disable-ssl
+.else
+USE_OPENSSL= yes
+.endif
-WRKSRC= ${WRKDIR}/x3270-3.1.1
-MAN1= x3270.1 x3270if.1 x3270-script.1 ibm_hosts.1
+WRKSRC= ${WRKDIR}/x3270-3.3
+MAN1= x3270.1
MANCOMPRESSED= yes
-USE_REINPLACE= yes
pre-install:
.if !exists(${X11BASE}/lib/X11/fonts/local)
@@ -33,14 +40,4 @@ pre-install:
@${ECHO} "*********************************************************"
.endif
-#
-# This patch is to make sure that mkversion.sh can be ran on FreeBSD 4-STABLE
-# which will get $(CLIENTENVSETUP) in its CC macro.
-#
-post-configure:
- ${REINPLACE_CMD} \
- -e 's,sh \./mkversion\.sh $$(CC),$$(CLIENTENVSETUP) sh ./mkversion.sh %%CC%%,' \
- -e 's,%%CC%%,${CC},' \
- ${WRKSRC}/Makefile
-
.include <bsd.port.mk>