aboutsummaryrefslogtreecommitdiffstats
path: root/x11/x3270
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /x11/x3270
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'x11/x3270')
-rw-r--r--x11/x3270/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 21ce12c4cdbc..aa8d03eadda3 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -23,9 +23,9 @@ USE_ICONV= yes
USE_XORG= ice sm x11 xaw xext xmu xt
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-pr3287 --with-fontdir=local --disable-dbcs
-CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" \
- LDFLAGS="-L${PREFIX}/lib" \
- LIBS="-L${PREFIX}/lib"
+CONFIGURE_ENV= LIBS="-L${PREFIX}/lib"
+CPPFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
.if defined(WITHOUT_OPENSSL)
CONFIGURE_ARGS+= --disable-ssl
.else