aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xbindkeys/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-12-29 23:04:03 +0800
committerijliao <ijliao@FreeBSD.org>2001-12-29 23:04:03 +0800
commit42e541b64fbcbda5890996c19a9a0e5be995307d (patch)
tree5394cc58938158451c5ca438090178d35bfcb11f /x11/xbindkeys/Makefile
parent4f324d1af56cf1205f046fbcc70de6af38a7f7e6 (diff)
downloadfreebsd-ports-gnome-42e541b64fbcbda5890996c19a9a0e5be995307d.tar.gz
freebsd-ports-gnome-42e541b64fbcbda5890996c19a9a0e5be995307d.tar.zst
freebsd-ports-gnome-42e541b64fbcbda5890996c19a9a0e5be995307d.zip
add xbindkeys 1.0.1
Allows you to launch shell commands under X with your keyboard
Diffstat (limited to 'x11/xbindkeys/Makefile')
-rw-r--r--x11/xbindkeys/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11/xbindkeys/Makefile b/x11/xbindkeys/Makefile
new file mode 100644
index 000000000000..4872adbec8ac
--- /dev/null
+++ b/x11/xbindkeys/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: xbindkeys
+# Date created: Dec 29, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xbindkeys
+PORTVERSION= 1.0.1
+CATEGORIES= x11
+MASTER_SITES= http://hocwp.free.fr/xbindkeys/
+
+MAINTAINER= ports@FreeBSD.org
+
+WITH_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${X11BASE}/include"
+
+MAN1= xbindkeys.1 xbindkeys_show.1
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xbindkeysrc ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>