aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xcb-proto/Makefile
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-09 00:09:22 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-09 00:09:22 +0800
commit7a9d5db1de1511f46e7229933b330a0a6e0639f9 (patch)
tree944e3f70e1a7bdbb7adf40b7be3cdc6de3ce743c /x11/xcb-proto/Makefile
parent6c44c83aafdaf44a839e171c2debd88fc6e985e3 (diff)
downloadfreebsd-ports-gnome-7a9d5db1de1511f46e7229933b330a0a6e0639f9.tar.gz
freebsd-ports-gnome-7a9d5db1de1511f46e7229933b330a0a6e0639f9.tar.zst
freebsd-ports-gnome-7a9d5db1de1511f46e7229933b330a0a6e0639f9.zip
The X protocol C-language Binding (XCB) is a replacement for Xlib
featuring a small footprint, latency hiding, direct access to the protocol, improved threading support, and extensibility. WWW: http://xcb.freedesktop.org/ - Ashish Shukla wahjava@gmail.com PR: ports/102446 Submitted by: Ashish Shukla <wahjava at gmail.com>
Diffstat (limited to 'x11/xcb-proto/Makefile')
-rw-r--r--x11/xcb-proto/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11/xcb-proto/Makefile b/x11/xcb-proto/Makefile
new file mode 100644
index 000000000000..6da7c692c07b
--- /dev/null
+++ b/x11/xcb-proto/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: xcb-proto
+# Date Created: 2006-08-23
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcb-proto
+PORTVERSION= 0.9.92
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= The X protocol C-language Binding (XCB) protocol
+
+BUILD_DEPENDS= xmllint:${PORTSDIR}/textproc/libxml2
+
+PREFIX?= ${X11BASE}
+USE_BZIP2= yes
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+DATADIR= ${PREFIX}/share/xcb
+
+.include <bsd.port.mk>