aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xcurs
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-10-07 20:08:15 +0800
committerwg <wg@FreeBSD.org>2014-10-07 20:08:15 +0800
commitb3530b480c05ba8526386f15f1e383b819b329ad (patch)
treef770e5c69c266af8d2b99aae7a578d5e492911f5 /x11/xcurs
parent51244563d2fd03d7da26d9202337b376f675ae58 (diff)
downloadfreebsd-ports-gnome-b3530b480c05ba8526386f15f1e383b819b329ad.tar.gz
freebsd-ports-gnome-b3530b480c05ba8526386f15f1e383b819b329ad.tar.zst
freebsd-ports-gnome-b3530b480c05ba8526386f15f1e383b819b329ad.zip
x11/xcurs: switch from py-imaging to py-pillow
- USES python With hat: python Approved by: portmgr (bdrewery, implicit)
Diffstat (limited to 'x11/xcurs')
-rw-r--r--x11/xcurs/Makefile6
-rw-r--r--x11/xcurs/files/patch-xcurs.py3
2 files changed, 5 insertions, 4 deletions
diff --git a/x11/xcurs/Makefile b/x11/xcurs/Makefile
index 3002c8bfe3dd..9d46f5e9834e 100644
--- a/x11/xcurs/Makefile
+++ b/x11/xcurs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xcurs
PORTVERSION= 0.5.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11 python
MASTER_SITES= http://freebsd.nsu.ru/distfiles/ \
#http://varg.dyndns.org/psi/files/xcurs/
@@ -11,10 +11,10 @@ MASTER_SITES= http://freebsd.nsu.ru/distfiles/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Editor for new X.Org style full-color cursors properties
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:${PORTSDIR}/graphics/py-pillow
+USES= python
USE_GNOME= pygtk2
-USE_PYTHON= yes
NO_BUILD= yes
post-patch:
diff --git a/x11/xcurs/files/patch-xcurs.py b/x11/xcurs/files/patch-xcurs.py
index d101a74e6e07..4b2b3e1f7513 100644
--- a/x11/xcurs/files/patch-xcurs.py
+++ b/x11/xcurs/files/patch-xcurs.py
@@ -14,7 +14,8 @@
import gtk.glade
@@ -8,7 +12,7 @@
import gladew
- import Image
+-import Image
++from PIL import Image
-import os, new, types
+import new, types