aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xfce4-conf
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /x11/xfce4-conf
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'x11/xfce4-conf')
-rw-r--r--x11/xfce4-conf/Makefile6
-rw-r--r--x11/xfce4-conf/pkg-plist18
2 files changed, 7 insertions, 17 deletions
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index 221546d60cd0..3dc54da86567 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-conf
PORTVERSION= 4.10.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= xfconf-${PORTVERSION}
@@ -57,8 +57,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-install:
-.if ${PORT_OPTIONS:MPERL}
- @${RM} ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod
-.endif
.include <bsd.port.mk>
diff --git a/x11/xfce4-conf/pkg-plist b/x11/xfce4-conf/pkg-plist
index bbb8f70791f2..03f867c80525 100644
--- a/x11/xfce4-conf/pkg-plist
+++ b/x11/xfce4-conf/pkg-plist
@@ -73,18 +73,12 @@ share/dbus-1/services/org.xfce.Xfconf.service
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfconf.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfconf.mo
%%PERLBIND%%%%PERL5_MAN3%%/Xfce4::Xfconf.3.gz
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4/Xfconf/Xfconf.so
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4/Xfconf/.packlist
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/Files.pm
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.h
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/xfconfperl-autogen.h
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.typemap
-%%PERLBIND%%%%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf.pm
-%%PERLBIND%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4/Xfconf
-%%PERLBIND%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Xfce4
-%%PERLBIND%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf/Install
-%%PERLBIND%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Xfce4/Xfconf
-%%PERLBIND%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Xfce4
+%%PERLBIND%%%%SITE_ARCH%%/auto/Xfce4/Xfconf/Xfconf.so
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/Files.pm
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.h
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/xfconfperl-autogen.h
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf/Install/xfconfperl.typemap
+%%PERLBIND%%%%SITE_ARCH%%/Xfce4/Xfconf.pm
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES