aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xlockmore
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-09-27 19:44:51 +0800
committertg <tg@FreeBSD.org>2001-09-27 19:44:51 +0800
commitb34c2ecb1c7c23bbdf834e9f2264f6e25902578f (patch)
tree088061bb350f643cf2f7c13c81c11e9d4ce50543 /x11/xlockmore
parent19957662f87126c61595f08c2a0ec031fbbd9cc7 (diff)
downloadfreebsd-ports-gnome-b34c2ecb1c7c23bbdf834e9f2264f6e25902578f.tar.gz
freebsd-ports-gnome-b34c2ecb1c7c23bbdf834e9f2264f6e25902578f.tar.zst
freebsd-ports-gnome-b34c2ecb1c7c23bbdf834e9f2264f6e25902578f.zip
Add ${KRB5_HOME}/include to $CFLAGS and ${KRB5_HOME}/lib to
$XLOCKLIBS for people using kerberos5. Suggested by: Niels Kroon <niels@fundum.net>
Diffstat (limited to 'x11/xlockmore')
-rw-r--r--x11/xlockmore/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11/xlockmore/Makefile b/x11/xlockmore/Makefile
index acb691bc9709..84d7aa752cf1 100644
--- a/x11/xlockmore/Makefile
+++ b/x11/xlockmore/Makefile
@@ -23,6 +23,8 @@ CONFIGURE_ARGS+= --enable-kerberos4
.endif
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --enable-kerberos5
+CFLAGS+= -I${KRB5_HOME}/include
+KRB5LIB= -L${KRB5_HOME}/lib
.endif
USE_X_PREFIX= yes
USE_XPM= yes
@@ -31,11 +33,12 @@ MAN1= xlock.1
WITH_MESAGL?= yes
.if ${WITH_MESAGL} == yes
CONFIGURE_ARGS+= --with-mesagl
-CONFIGURE_ENV+= XLOCKLIBS="${PTHREAD_LIBS}"
+MESALIB= ${PTHREAD_LIBS}
USE_MESA= yes
.else
CONFIGURE_ARGS+= --without-mesagl --without-opengl
.endif
+CONFIGURE_ENV+= XLOCKLIBS="${KRB5LIB} ${MESALIB}"
.include <bsd.port.pre.mk>