aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xmove
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-03-14 06:46:51 +0800
committersf <sf@FreeBSD.org>2001-03-14 06:46:51 +0800
commit7cec423c54c46bee72764c375c193ee31197bff8 (patch)
tree42f69483cbfed372f9b3d36d8a264e26157a073e /x11/xmove
parent7947a8136590e11f5726de8070f3da2819c14cbe (diff)
downloadfreebsd-ports-gnome-7cec423c54c46bee72764c375c193ee31197bff8.tar.gz
freebsd-ports-gnome-7cec423c54c46bee72764c375c193ee31197bff8.tar.zst
freebsd-ports-gnome-7cec423c54c46bee72764c375c193ee31197bff8.zip
o copying files/Imakefile instead of Makefile to make USE_IMAKE working.
o making/installing html manpages. o replace magic number with macro in DISTNAME. o move post-extract to post-patch to get as-is distfile after make extract.
Diffstat (limited to 'x11/xmove')
-rw-r--r--x11/xmove/Makefile14
-rw-r--r--x11/xmove/files/Imakefile6
-rw-r--r--x11/xmove/files/Makefile8
3 files changed, 13 insertions, 15 deletions
diff --git a/x11/xmove/Makefile b/x11/xmove/Makefile
index 17d3730742ef..029d3f356fe7 100644
--- a/x11/xmove/Makefile
+++ b/x11/xmove/Makefile
@@ -9,7 +9,7 @@ PORTNAME= xmove
PORTVERSION= 2.0b2
CATEGORIES= x11
MASTER_SITES= ftp://ftp.cs.columbia.edu/pub/xmove/
-DISTNAME= ${PORTNAME}.2.0beta2
+DISTNAME= ${PORTNAME}.${PORTVERSION:S/b/beta/}
MAINTAINER= sec@42.org
@@ -20,12 +20,12 @@ USE_IMAKE= yes
MAN1= xmove.1 xmovectrl.1
-post-extract:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-post-install:
-.for man in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/man/man1/${man} ${X11BASE}/man/man1
-.endfor
+post-patch:
+ ${CP} ${FILESDIR}/Imakefile ${WRKSRC}
+ (cd ${WRKSRC}; \
+ ${CP} man/man1/xmove.1 xmove/xmove.man; \
+ ${CP} man/man1/xmovectrl.1 xmovectrl/xmovectrl.man)
.include <bsd.port.mk>
diff --git a/x11/xmove/files/Imakefile b/x11/xmove/files/Imakefile
new file mode 100644
index 000000000000..c021507b2a8a
--- /dev/null
+++ b/x11/xmove/files/Imakefile
@@ -0,0 +1,6 @@
+#define IHaveSubdirs
+#define PassCDebugFlags CDEBUGFLAGS="$(CDEBUGFLAGS)"
+
+SUBDIRS= xmove xmovectrl
+MakeSubdirs($(SUBDIRS))
+DependSubdirs($(SUBDIRS))
diff --git a/x11/xmove/files/Makefile b/x11/xmove/files/Makefile
deleted file mode 100644
index 8bab179214b5..000000000000
--- a/x11/xmove/files/Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
-# $FreeBSD$
-
-all:
- cd xmove;xmkmf -DBuildHtmlManPages=0 && make
- cd xmovectrl;xmkmf -DBuildHtmlManPages=0 && make
-install:
- cd xmove;make install
- cd xmovectrl;make install