aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xnee/Makefile
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2007-08-05 03:29:45 +0800
committerlme <lme@FreeBSD.org>2007-08-05 03:29:45 +0800
commit85488fc2d92837f6c8b5129b09a95496e1d77a24 (patch)
treea83651d97962595238284cf3681b8fd72fb4c5a4 /x11/xnee/Makefile
parent9bcc75aeafcf2f8c365f8d11ef22cae9d869eee6 (diff)
downloadfreebsd-ports-gnome-85488fc2d92837f6c8b5129b09a95496e1d77a24.tar.gz
freebsd-ports-gnome-85488fc2d92837f6c8b5129b09a95496e1d77a24.tar.zst
freebsd-ports-gnome-85488fc2d92837f6c8b5129b09a95496e1d77a24.zip
Update to 3.01
PR: ports/114744 Submitted by: KATO Tsuguru <tkato432 (AT) yahoo.com> Approved by: miwi (mentor)
Diffstat (limited to 'x11/xnee/Makefile')
-rw-r--r--x11/xnee/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index 076ff3128a4c..c57821658063 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xnee
-PORTVERSION= 2.06
+PORTVERSION= 3.01
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -24,8 +24,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-cli --disable-doc
-MAN1= cnee.1
-INFO= cnee xnee
+MAN1= cnee.1 xnee.1
+INFO= cnee
PLIST_FILES= bin/cnee \
%%DATADIR%%/example1.xns \
%%DATADIR%%/pixmaps/xnee.png \
@@ -43,8 +43,16 @@ MAKEINFO= ${LOCALBASE}/bin/makeinfo
MAKEINFO= /usr/bin/makeinfo
.endif
+.if ${OSVERSION} < 600000
+BUILD_DEPENDS+= ${MAKEINFO_CMD}:${PORTSDIR}/print/texinfo
+MAKEINFO_CMD= ${LOCALBASE}/bin/makeinfo
+.else
+MAKEINFO_CMD= /usr/bin/makeinfo
+.endif
+
.if defined(WITH_GNEE)
USE_GNOME+= gtk20
+MAN1+= gnee.1
PLIST_FILES+= bin/gnee
.else
CONFIGURE_ARGS+= --disable-gui
@@ -80,11 +88,9 @@ post-patch:
's|cp $$(PNEE)|$$(INSTALL_PROGRAM) $$(PNEE)|g' ${WRKSRC}/pnee/src/Makefile.in
post-build:
- cd ${WRKSRC}/cnee/src && ${MAKEINFO} --no-split cnee.texi
- cd ${WRKSRC}/doc && ${MAKEINFO} --no-split xnee.texi
+ cd ${WRKSRC}/cnee/src && ${MAKEINFO_CMD} --no-split cnee.texi
post-install:
${INSTALL_DATA} ${WRKSRC}/cnee/src/cnee.info ${PREFIX}/${INFO_PATH}
- ${INSTALL_DATA} ${WRKSRC}/doc/xnee.info ${PREFIX}/${INFO_PATH}
.include <bsd.port.post.mk>