aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xpra
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-09-05 00:25:43 +0800
committerjkim <jkim@FreeBSD.org>2015-09-05 00:25:43 +0800
commitcd86247c92d90b5efffd6aee39d5e80dd91a813d (patch)
treec25a00f40685d2e4327311561b2c476e706f3121 /x11/xpra
parent6ddaf942532fd71c19437fc7eb74a72da7931c37 (diff)
downloadfreebsd-ports-gnome-cd86247c92d90b5efffd6aee39d5e80dd91a813d.tar.gz
freebsd-ports-gnome-cd86247c92d90b5efffd6aee39d5e80dd91a813d.tar.zst
freebsd-ports-gnome-cd86247c92d90b5efffd6aee39d5e80dd91a813d.zip
Update to 0.15.5.
Diffstat (limited to 'x11/xpra')
-rw-r--r--x11/xpra/Makefile2
-rw-r--r--x11/xpra/distinfo4
-rw-r--r--x11/xpra/files/patch-xpra_net_compression.py4
3 files changed, 5 insertions, 5 deletions
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index 5914c4c6f61b..959d26ea8033 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xpra
-PORTVERSION= 0.15.4
+PORTVERSION= 0.15.5
CATEGORIES= x11
MASTER_SITES= http://xpra.org/src/
diff --git a/x11/xpra/distinfo b/x11/xpra/distinfo
index a4c086632e84..384a8c0ef70d 100644
--- a/x11/xpra/distinfo
+++ b/x11/xpra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xpra-0.15.4.tar.xz) = 29be80b8987dd131058aab0a1c8d456a7ac67ad56c54d2b5e72472ff003799a2
-SIZE (xpra-0.15.4.tar.xz) = 1194484
+SHA256 (xpra-0.15.5.tar.xz) = bcd258e8a0af4d074da09c898f0b80b5ea09513782184e06c6003f31365dfb9a
+SIZE (xpra-0.15.5.tar.xz) = 1195776
diff --git a/x11/xpra/files/patch-xpra_net_compression.py b/x11/xpra/files/patch-xpra_net_compression.py
index 51f87fc4e265..5084886f6fdb 100644
--- a/x11/xpra/files/patch-xpra_net_compression.py
+++ b/x11/xpra/files/patch-xpra_net_compression.py
@@ -1,4 +1,4 @@
---- xpra/net/compression.py.orig 2015-07-27 14:25:13 UTC
+--- xpra/net/compression.py.orig 2015-08-25 09:32:59 UTC
+++ xpra/net/compression.py
@@ -23,7 +23,9 @@ try:
return level | LZ4_FLAG, LZ4_compress(packet)
@@ -15,7 +15,7 @@
#we want at least two numbers first:
if len(tmpv)>=2:
#ie: (0, 7, 0)
-- lz4_version = ".".join(tmpv)
+- lz4_version = ".".join([str(x) for x in tmpv])
- assert lz4_version>="0.7", "versions older than 0.7.0 are vulnerable and should not be used, see CVE-2014-4715"
- if hasattr(lz4, "LZ4_VERSION"):
- lz4_version += "."+str(lz4.LZ4_VERSION)