aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xscreensaver-gnome/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-08-03 01:50:54 +0800
committersobomax <sobomax@FreeBSD.org>2002-08-03 01:50:54 +0800
commit14b5b15ddd5e89fc14057d383e44b89fcd4cf6c0 (patch)
tree1b049719c92b219433a2db225ff9e623fb44d30c /x11/xscreensaver-gnome/Makefile
parentaa8668d1a2079eaeb36c2d3edc6892a66b513da4 (diff)
downloadfreebsd-ports-gnome-14b5b15ddd5e89fc14057d383e44b89fcd4cf6c0.tar.gz
freebsd-ports-gnome-14b5b15ddd5e89fc14057d383e44b89fcd4cf6c0.tar.zst
freebsd-ports-gnome-14b5b15ddd5e89fc14057d383e44b89fcd4cf6c0.zip
Put flameproof asbestos on and commit diversification of xscreensaver
and xscreensaver-gnome, so that GNOME components now is fully independent from the main xscreensaver port. Unfortunately all numerous attempts of GNOME team to put xscreensaver's maintainer into a co-operative mode failed, so that this commit goes in unreviewed. In addition, prevent xscreensaver from detecting gtk/glib/libxml-2.0 when it is not asked for, remove stale warning, use USE_GNOMENG and detect/use libintl properly. This expected to significantly decrease number of "xscreensaver doesn't work with GNOME" complains in freebsd-gnome mailing list. Approved by: maintainer's timeout
Diffstat (limited to 'x11/xscreensaver-gnome/Makefile')
-rw-r--r--x11/xscreensaver-gnome/Makefile48
1 files changed, 45 insertions, 3 deletions
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index 538a67216d36..2c2a53abfc86 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -5,12 +5,54 @@
# $FreeBSD$
#
+MAINDIR= ${.CURDIR}/../xscreensaver
+
+PORTNAME= xscreensaver-gnome
+PORTVERSION!= ${MAKE} -V PORTVERSION -f ${MAINDIR}/${MAKEFILE}
+PORTREVISION!= ${MAKE} -V PORTREVISION -f ${MAINDIR}/${MAKEFILE}
+PORTEPOCH!= ${MAKE} -V PORTEPOCH -f ${MAINDIR}/${MAKEFILE}
CATEGORIES= x11 gnome
+DISTFILES=
MAINTAINER= gnome@FreeBSD.org
-MASTERDIR= ${.CURDIR}/../xscreensaver
+FETCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11/xscreensaver:patch
+BUILD_DEPENDS!= ${MAKE} -V BUILD_DEPENDS -f ${MAINDIR}/${MAKEFILE}
+LIB_DEPENDS!= ${MAKE} -V LIB_DEPENDS -f ${MAINDIR}/${MAKEFILE}
+RUN_DEPENDS!= ${MAKE} -V RUN_DEPENDS -f ${MAINDIR}/${MAKEFILE}
+
+RUN_DEPENDS+= xscreensaver:${PORTSDIR}/x11/xscreensaver
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehier gnomelibs libcapplet gdkpixbuf
+GNU_CONFIGURE= yes
+OLD_CONFIGURE_ARGS!= ${MAKE} -V CONFIGURE_ARGS -f ${MAINDIR}/${MAKEFILE}
+CONFIGURE_ARGS= ${OLD_CONFIGURE_ARGS:N--without-gnome} --with-gnome
+CONFIGURE_ENV!= ${MAKE} -V CONFIGURE_ENV -f ${MAINDIR}/${MAKEFILE}
+
+post-extract:
+ @${CP} -Rp ${WRKDIRPREFIX}${MAINDIR}/work/xscreensaver-${PORTVERSION} \
+ ${WRKSRC}
+ @${RM} -f ${WRKSRC}/config.cache
+
+do-build:
+ @cd ${WRKSRC}/driver && ${GMAKE} clean xscreensaver-demo \
+ screensaver-properties.desktop
-WITH_GNOME= yes
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/utils/images/screensaver-*.xpm \
+ ${PREFIX}/share/gnome/pixmaps
+ @${INSTALL_DATA} ${WRKSRC}/utils/images/logo-50.xpm \
+ ${PREFIX}/share/gnome/pixmaps/xscreensaver.xpm
+ @${INSTALL_PROGRAM} ${WRKSRC}/driver/xscreensaver-demo \
+ ${PREFIX}/bin/xscreensaver-gnome
+ @${INSTALL_SCRIPT} ${WRKSRC}/driver/screensaver-properties-capplet \
+ ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/driver/screensaver-properties.desktop \
+ ${PREFIX}/share/gnome/apps/Settings/Desktop
+ @${INSTALL_DATA} ${WRKSRC}/driver/screensaver-properties.desktop \
+ ${PREFIX}/share/gnome/control-center/Desktop
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>