aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xsel/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-04-13 12:11:02 +0800
committerdanfe <danfe@FreeBSD.org>2015-04-13 12:11:02 +0800
commit2fdec69e1ab96d0cb184d7b6e0fd7c545297b4a7 (patch)
tree86907bba0974735f951e4b7489ab339fa3606ad3 /x11/xsel/Makefile
parentcc69535d798bed9ff166e6326ada73a823bcd589 (diff)
downloadfreebsd-ports-gnome-2fdec69e1ab96d0cb184d7b6e0fd7c545297b4a7.tar.gz
freebsd-ports-gnome-2fdec69e1ab96d0cb184d7b6e0fd7c545297b4a7.tar.zst
freebsd-ports-gnome-2fdec69e1ab96d0cb184d7b6e0fd7c545297b4a7.zip
- Provide new mastersite (CENKES is no more) and unbreak
- Define LICENSE (MIT), augment COMMENT, fix the header - Add missing OPTIONS_DEFINE, replace ${INSTALL} -d with ${MKDIR}, perform few other minor Makefile cleanups - Remove defunct WWW from port description - Transfer maintainership to the submitter PR: 199326 Submitted by: Chris Hutchinson
Diffstat (limited to 'x11/xsel/Makefile')
-rw-r--r--x11/xsel/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/x11/xsel/Makefile b/x11/xsel/Makefile
index c9cdc74afa1d..2abd6091a73e 100644
--- a/x11/xsel/Makefile
+++ b/x11/xsel/Makefile
@@ -1,33 +1,38 @@
-# Created by: ijliao
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
PORTNAME= xsel
PORTVERSION= 0.04.1
PORTREVISION= 5
CATEGORIES= x11
-MASTER_SITES= CENKES
-#http://www.niksula.cs.hut.fi/~vherva/xsel/xsel.{c,man}
+MASTER_SITES= http://BSDforge.com/projects/source/x11/xsel/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Access X selection from command line
+MAINTAINER= portmaster@BSDforge.com
+COMMENT= Access X11 selection buffer from command line
-BROKEN= No public distfiles
+LICENSE= MIT
-CONFLICTS= xsel-conrad-[0-9]*
-USES= tar:bzip2
+CONFLICTS_INSTALL= xsel-conrad-[0-9]*
+
+USES= tar:bzip2
USE_XORG= xmu xaw xt xproto xkbfile
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lXt -lXaw -lX11 -lXmu
+
PLIST_FILES= bin/${PORTNAME} man/man1/xsel.1.gz
PORTDOCS= ${PORTNAME}.html
+OPTIONS_DEFINE= DOCS
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
- ${INSTALL} -d ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>