aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xsel
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-10-28 09:20:21 +0800
committereadler <eadler@FreeBSD.org>2013-10-28 09:20:21 +0800
commit1539e8eb9c0e4a5e085eeb5e6c891b068cc858bd (patch)
tree6f4f2ae45e1c369818400159455396ca1e1f86b8 /x11/xsel
parent6999fceec6fe05a85fee8f48d3a438a056fef437 (diff)
downloadfreebsd-ports-gnome-1539e8eb9c0e4a5e085eeb5e6c891b068cc858bd.tar.gz
freebsd-ports-gnome-1539e8eb9c0e4a5e085eeb5e6c891b068cc858bd.tar.zst
freebsd-ports-gnome-1539e8eb9c0e4a5e085eeb5e6c891b068cc858bd.zip
Cleanup of the ports in the x11 directory
- Convert to staging
Diffstat (limited to 'x11/xsel')
-rw-r--r--x11/xsel/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/x11/xsel/Makefile b/x11/xsel/Makefile
index fc0d833bdf23..8cbc247ea0b5 100644
--- a/x11/xsel/Makefile
+++ b/x11/xsel/Makefile
@@ -16,22 +16,19 @@ USE_BZIP2= yes
USE_XORG= xmu xaw xt xproto xkbfile
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lXt -lXaw -lX11 -lXmu
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} man/man1/xsel.1.gz
PORTDOCS= ${PORTNAME}.html
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-build:
- @cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS}
+ cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL} -d ${DOCSDIR}/
- @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+ ${INSTALL} -d ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.endif
-.include <bsd.port.mk>