aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xsnow/Makefile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2001-12-10 12:04:33 +0800
committerjmz <jmz@FreeBSD.org>2001-12-10 12:04:33 +0800
commit945d9c93dd23350d970ae98c7612aeb666633211 (patch)
tree0f09e16c78df63aa5dc33160aeb085df6e19162a /x11/xsnow/Makefile
parente3da4c7d24958e688aae3cb13f214cf9320671f8 (diff)
downloadfreebsd-ports-gnome-945d9c93dd23350d970ae98c7612aeb666633211.tar.gz
freebsd-ports-gnome-945d9c93dd23350d970ae98c7612aeb666633211.tar.zst
freebsd-ports-gnome-945d9c93dd23350d970ae98c7612aeb666633211.zip
Move the configuration bits from scripts/ into Makefile, using a pre-build
target to patch ${WRKSRC}/Makefile. This should fix an install problem with XFree86-4.
Diffstat (limited to 'x11/xsnow/Makefile')
-rw-r--r--x11/xsnow/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11/xsnow/Makefile b/x11/xsnow/Makefile
index 1443209e6306..d122e1fa9d6e 100644
--- a/x11/xsnow/Makefile
+++ b/x11/xsnow/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xsnow
PORTVERSION= 1.40
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
@@ -17,6 +18,12 @@ MAINTAINER= jmz@FreeBSD.org
USE_IMAKE= yes
MAN6= xsnow.6
+pre-build:
+ @cd ${WRKSRC} && ${MV} Makefile Makefile~ && ${SED} \
+ -e 's: BINDIR .*:BINDIR=${PREFIX}/bin:' \
+ -e 's: MANDIR .*:MANDIR=${PREFIX}/man/man6:' \
+ -e 's: MANSUFFIX .*:MANSUFFIX=6:' <Makefile~ >Makefile
+
pre-install:
@${MKDIR} ${PREFIX}/bin
@${MKDIR} ${PREFIX}/man/man6