aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xterm
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-06-21 04:28:34 +0800
committerstas <stas@FreeBSD.org>2009-06-21 04:28:34 +0800
commitbb999548ddafe690b20dadb1d4ac4bb870049f55 (patch)
treef12bc9abb60fde2a5852e5db68360e0b12a62c9a /x11/xterm
parent370945ab391c46c92cbf91c57e84e0dfbc6d1ca1 (diff)
downloadfreebsd-ports-gnome-bb999548ddafe690b20dadb1d4ac4bb870049f55.tar.gz
freebsd-ports-gnome-bb999548ddafe690b20dadb1d4ac4bb870049f55.tar.zst
freebsd-ports-gnome-bb999548ddafe690b20dadb1d4ac4bb870049f55.zip
- Enable wide characters by default. Give a note, that 8-bit copy/paste
may not work in widechar xterm, and how to revert is to the old behaviour. Approved by: krion (maintainer)
Diffstat (limited to 'x11/xterm')
-rw-r--r--x11/xterm/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 0677d155b004..15ec9c7cb4b7 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xterm
PORTVERSION= 243
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://invisible-island.net/xterm/ \
http://voodoo.bawue.com/download/
@@ -24,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--with-utempter --enable-narrowproto
-.if defined(WITH_WIDE_CHARS)
+.if !defined(WITHOUT_WIDE_CHARS)
CONFIGURE_ARGS+= --enable-wide-chars --enable-luit
.endif
@@ -36,5 +37,22 @@ MAN1= resize.1 koi8rxterm.1 uxterm.1 xterm.1
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/xterm
+.if !defined(WITHOUT_WIDE_CHARS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} '********************************************************'
+ @${ECHO_MSG} ' NOTE: you installed xterm with wide chars support.'
+ @${ECHO_MSG} ' This introduces some limitations comparing to the'
+ @${ECHO_MSG} ' plain single chars version: this version of xterm'
+ @${ECHO_MSG} ' will use UTF-8 charset for selection buffers,'
+ @${ECHO_MSG} ' breaking 8-bit copy/paste support unless you are'
+ @${ECHO_MSG} ' using UTF-8 or ISO8859-1 locale. If you want'
+ @${ECHO_MSG} ' 8-bit charset selections to work as before, use'
+ @${ECHO_MSG} ' "eightBitSelectTypes" XTerm resource setting.'
+ @${ECHO_MSG}
+ @${ECHO_MSG} ' For further information refer to the SELECT/PASTE'
+ @${ECHO_MSG} ' section of xterm(1) manual page.'
+ @${ECHO_MSG} '********************************************************'
+ @${ECHO_MSG}
+.endif
.include <bsd.port.mk>