aboutsummaryrefslogtreecommitdiffstats
path: root/x11/yeahconsole
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-11-09 23:27:25 +0800
committerdanfe <danfe@FreeBSD.org>2013-11-09 23:27:25 +0800
commit1af2401384c817cb9f25bb02d3d149e048b8fe6d (patch)
tree46a021e9e9b62348f9d3b661f5c93c4c58d862b5 /x11/yeahconsole
parent18b7c90a12ca2b3a7ce077981fd6363febfcb821 (diff)
downloadfreebsd-ports-gnome-1af2401384c817cb9f25bb02d3d149e048b8fe6d.tar.gz
freebsd-ports-gnome-1af2401384c817cb9f25bb02d3d149e048b8fe6d.tar.zst
freebsd-ports-gnome-1af2401384c817cb9f25bb02d3d149e048b8fe6d.zip
- Clean up patch, honor LOCALBASE, CC, CFLAGS; add LICENSE, stagify
- Install README file (useful documentation, also acts as changelog) - Provide better COMMENT and port description (courtesy of OpenBSD)
Diffstat (limited to 'x11/yeahconsole')
-rw-r--r--x11/yeahconsole/Makefile16
-rw-r--r--x11/yeahconsole/files/patch-Makefile32
-rw-r--r--x11/yeahconsole/pkg-descr7
3 files changed, 31 insertions, 24 deletions
diff --git a/x11/yeahconsole/Makefile b/x11/yeahconsole/Makefile
index 8d3d541bea08..6460623e3015 100644
--- a/x11/yeahconsole/Makefile
+++ b/x11/yeahconsole/Makefile
@@ -1,4 +1,4 @@
-# Created by: asami
+# Created by: Satoshi Asami <asami@FreeBSD.org>
# $FreeBSD$
PORTNAME= yeahconsole
@@ -7,11 +7,21 @@ CATEGORIES= x11
MASTER_SITES= http://phrat.de/
MAINTAINER= ports@FreeBSD.org
-COMMENT= quake console-like extension for X terminals
+COMMENT= Terminal wrapper for creating drop-down consoles
+
+LICENSE= GPLv2
USE_XORG= x11
+ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/yeahconsole
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11/yeahconsole/files/patch-Makefile b/x11/yeahconsole/files/patch-Makefile
index 6df806381d5a..526cb8be044b 100644
--- a/x11/yeahconsole/files/patch-Makefile
+++ b/x11/yeahconsole/files/patch-Makefile
@@ -1,37 +1,33 @@
--- Makefile.orig 2006-01-14 18:54:05.000000000 +0300
+++ Makefile 2008-04-30 12:23:01.000000000 +0400
-@@ -5,26 +5,26 @@
+@@ -1,24 +1,23 @@
+ TARGET = yeahconsole
+-CC = gcc
++CC ?= gcc
+ #CC = cc
+ INSTALL = install
PREFIX = /usr/local
--LIBS = -lX11
+ LIBS = -lX11
-INCLUDES = -I/usr/X11R6/include
-LIB_DIRS = -L/usr/X11R6/lib
-FLAGS = -Os -Wall
-+LIBS = -lX11
-+INCLUDES = -I/usr/local/include
-+LIB_DIRS = -L/usr/local/lib
-+CFLAGS? = -Os -Wall
++INCLUDES = -I$(LOCALBASE)/include
++LIB_DIRS = -L$(LOCALBASE)/lib
++CFLAGS ?= -Os -Wall
OBJECTS := yeahconsole.o
SOURCES := yeahconsole.c
$(TARGET): $(OBJECTS)
- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
-+ $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $(SOURCES)
- strip $@
+- strip $@
++ $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $>
$(OBJECTS): $(SOURCES)
- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
--
-+ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $(SOURCES)
-+all: $(TARGET)
++ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
+
clean:
rm -rf $(TARGET) $(OBJECTS)
-
- install: $(TARGET) $(MAN)
-- $(INSTALL) -o root -g root -m 0755 $(TARGET) $(PREFIX)/bin
-+ $(INSTALL) -o root -g wheel -m 0755 $(TARGET) $(PREFIX)/bin
-
-
- uninstall:
diff --git a/x11/yeahconsole/pkg-descr b/x11/yeahconsole/pkg-descr
index 5bbd42af3dfd..4684b0e56ed5 100644
--- a/x11/yeahconsole/pkg-descr
+++ b/x11/yeahconsole/pkg-descr
@@ -1,5 +1,6 @@
-YeahConsole turns an xterm into a gamelike console.
-This means it will slide down from top of your screen
-if you hit a shortcut key.
+YeahConsole is a terminal wrapper for creating drop-down consoles, similar
+to those found in games like Quake.
+
+By default, YeahConsole is activated and hidden with Ctrl+Alt+Y.
WWW: http://phrat.de/yeahtools.html