aboutsummaryrefslogtreecommitdiffstats
path: root/x11/yelp/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
committermarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
commit0b42143dea1a55d0f1f6d09704bbc131e1b633ed (patch)
treebc54902eb18f738e45a91362b2b0faf1ec6d04fa /x11/yelp/Makefile
parent773c9ca4ac44ac67652d01f1e985e4df8dab5301 (diff)
downloadfreebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.gz
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.zst
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Diffstat (limited to 'x11/yelp/Makefile')
-rw-r--r--x11/yelp/Makefile80
1 files changed, 76 insertions, 4 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 06d274d2aac8..880ac2eed127 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -6,23 +6,95 @@
#
PORTNAME= yelp
-PORTVERSION= 2.6.5
+PORTVERSION= 2.9.3
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.9
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A help browser for the GNOME 2 desktop
+BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-doc-utils.pc:${PORTSDIR}/textproc/gnomedocutils \
+ ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-doc-utils.pc:${PORTSDIR}/textproc/gnomedocutils \
+ ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+
+MOZILLA= mozilla
+HEADERS_SUFX=
+
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla
+HEADERS_SUFX=
+.else
+.if ${WITH_MOZILLA}=="firefox"
+MOZILLA= firefox
+.else
+.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+MOZILLA= mozilla-devel
+HEADERS_SUFX= -devel
+.else
+MOZILLA= mozilla
+HEADERS_SUFX=
+.endif
+.endif
+.endif
+
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libgtkhtml
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-man \
+ --enable-info \
+ --with-mozilla=${MOZILLA}
MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
-.include <bsd.port.mk>
+GCONF_SCHEMAS= yelp.schemas
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+.if ${MOZILLA}=="mozilla-devel"
+USE_GCC= 3.4
+.endif
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default yelp uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG}
+ @${ECHO_MSG} " mozilla-devel "
+ @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} ""
+
+post-patch:
+.if defined(WITH_MOZILLA) && ${WITH_MOZILLA}=="mozilla-devel"
+ @${REINPLACE_CMD} -e 's|xmozilla|xmozilla-devel|g; \
+ s|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g; \
+ s|$$MOZILLA-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g' \
+ ${WRKSRC}/configure
+.endif
+
+post-configure:
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%MOZILLA%%|${MOZILLA}|g' <${FILESDIR}/yelp.sh \
+ > ${WRKDIR}/yelp.sh
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; \
+ s|%%MOZILLA%%|${MOZILLA}|g' <${FILESDIR}/gnome-help.sh \
+ > ${WRKDIR}/gnome-help.sh
+
+post-install:
+ ${MV} -f ${PREFIX}/bin/yelp ${PREFIX}/bin/yelp-bin
+ ${MV} -f ${PREFIX}/bin/gnome-help ${PREFIX}/bin/gnome-help-bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/yelp.sh ${PREFIX}/bin/yelp
+ ${INSTALL_SCRIPT} ${WRKDIR}/gnome-help.sh ${PREFIX}/bin/gnome-help
+
+.include <bsd.port.post.mk>