aboutsummaryrefslogtreecommitdiffstats
path: root/x11/yelp/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /x11/yelp/Makefile
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'x11/yelp/Makefile')
-rw-r--r--x11/yelp/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 98532139cc2f..a80939317c25 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -3,39 +3,38 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/x11/yelp/Makefile,v 1.63 2005/10/09 00:42:45 marcus Exp $
#
PORTNAME= yelp
-PORTVERSION= 2.10.0
+PORTVERSION= 2.12.1
PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A help browser for the GNOME 2 desktop
-BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-doc-utils.pc:${PORTSDIR}/textproc/gnomedocutils \
- ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-doc-utils.pc:${PORTSDIR}/textproc/gnomedocutils \
- ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-MOZILLA= mozilla
+MOZILLA= firefox
HEADERS_SUFX=
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
+MOZILLA= firefox
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="firefox"
-MOZILLA= firefox
+.if ${WITH_MOZILLA}=="mozilla"
+MOZILLA= mozilla
.else
.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= mozilla-devel
HEADERS_SUFX= -devel
.else
-MOZILLA= mozilla
+MOZILLA= firefox
HEADERS_SUFX=
.endif
.endif
@@ -45,8 +44,9 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
-USE_LIBTOOL_VER=15
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui gnomedocutils
+USE_AUTOTOOLS= libtool:15
+INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-mozilla=${MOZILLA}
@@ -75,11 +75,11 @@ CONFIGURE_ARGS+=--enable-info
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default yelp uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " By default yelp uses www/firefox for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
@${ECHO_MSG} " mozilla-devel "
- @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} " mozilla"
@${ECHO_MSG} ""
post-patch:
dbdb9d09'>New port: databases/rubygem-pl-puppetdb-rubyromain2019-05-151-0/+1 * Add py-tiledb 0.4.1sunpoet2019-05-131-0/+1 * Add tiledb 1.5.0sunpoet2019-05-131-0/+1 * Remove expired ports:rene2019-05-091-2/+0 * Remove expired ports of Haskell libraries.arrowd2019-05-091-6/+0 * lang/ruby2[45]: Remove dbm library and replace it with databases/rubygem-dbmmeta2019-04-301-0/+1 * Remove expired ports:rene2019-04-281-2/+0 * Added new port required by Gitlab-ce.mfechner2019-04-251-0/+1 * New port: databases/mongodb40-toolstobik2019-04-191-0/+1 * Add py-tableschema 1.4.0sunpoet2019-04-161-0/+1 * Add rubygem-state_machines-activerecord05 0.5.2 (copied from rubygem-state_ma...sunpoet2019-04-131-0/+1 * Remove expired ports:rene2019-04-051-3/+0 * databases/ruby-gdbm: Gemify gdbmmeta2019-04-021-1/+1 * Remove expired ports:tobik2019-04-021-5/+0 * databases/automysqlbackup: Add the port to the treemmokhi2019-03-281-0/+1 * Qt4 deprecation: Remove Qt4 and its consumes.tcberner2019-03-171-10/+0 * - Repocopy postgis24 --> postgis25 and update to 2.5.2wen2019-03-151-0/+1 * Add py-sqlalchemy13 1.3.1 (copied from py-sqlalchemy12)sunpoet2019-03-101-0/+1 * Remove expired ports:rene2019-03-031-2/+0 * New port: databases/mongodb40pi2019-03-021-0/+1 * Remove databases/py-sqlparse01sunpoet2019-03-011-1/+0 * - Repocopy py-pg8000 --> py-pg8000-112 and downgrade to 1.12.5wen2019-02-141-0/+1 * Hook ldb14 to the buildantoine2019-02-101-0/+1 * New port: databases/cassandra3: Highly scalable distributed databaseyuri2019-01-281-0/+1 * Sort categories Makefiles.mat2019-01-231-8/+8 * Add py-pglast 1.1sunpoet2019-01-141-0/+1 * Remove expired ports:rene2019-01-101-8/+0 * Update databases/mysql-connector-java to 8.0.13matthew2019-01-091-0/+1 * Hook up databases/py-mongoengine after the move and unbreak indextobik2019-01-081-0/+1 * Add p5-Search-Xapian 1.2.25.2 (copied from p5-Search-Xapian12)sunpoet2019-01-061-0/+1 * databases/p5-DBIx-Class-Storage-TxnEndHook: create portswills2019-01-061-0/+1 * databases/p5-DBIx-Class-InflateColumn-Serializer: create portswills2019-01-061-0/+1 * databases/p5-DBIx-Class-AuditLog: create portswills2019-01-061-0/+1 * databases/p5-CHI-Driver-TokyoTyrant: create portswills2019-01-061-0/+1 * Move databases/php7-tarantool to databases/php-tarantoolsunpoet2019-01-041-1/+1 * Remove expired php56- ports:rene2019-01-011-16/+0 * Remove expired ports:rene2019-01-011-2/+0 * Remove KDE4, part 5rene2019-01-011-1/+0 * Remove expired ports:rene2018-12-311-2/+0 * Remove expired ports:rene2018-12-311-11/+0 * Renamed port and changed dep to rails50 as gitlab-ce 11.6 depends now on rail...mfechner2018-12-231-1/+1 * Renamed port and changed dep to rails50 as gitlab-ce 11.6 depends now on rail...mfechner2018-12-231-1/+1 * databases/portsgresql-prefix: Prefix Range module for PostgreSQLdbn2018-12-151-0/+1 * Add gom.kwm2018-12-091-0/+1 * Remove expired ports:rene2018-12-051-13/+0 * New Port: databases/pgpool-II-40joneum2018-11-161-0/+1 * The PostgreSQL Global Development Group today announced the release ofgirgen2018-10-201-0/+8 * This is a MongoDB to Moose object mapper. This module allows you to usewen2018-10-131-0/+1 * Connect all the PHP 7.3 portstz2018-10-081-0/+13 * A modern, feature-rich and highly-tunable Python client library forwen2018-10-011-0/+1 * New port: databases/sequelertobik2018-09-301-0/+1 * New port: databases/puppetdb-cliromain2018-09-271-0/+1 * New port: databases/puppetdb6romain2018-09-271-0/+2 * databases/couchdb2: new port via PR#218844dch2018-09-211-0/+1 * New port: databases/opendbviewertobik2018-09-201-0/+1 * Remove expired ports:rene2018-08-211-1/+0 * Remove expired ports:rene2018-08-171-1/+0 * Add p5-BSON-XS 0.4.3sunpoet2018-08-161-0/+1 * Remove expired port:rene2018-08-151-1/+0 * Regular sorting of categories Makefiles.mat2018-08-081-1/+1 * Remove expired ports:rene2018-08-021-1/+0 * Remove expired ports:rene2018-08-021-1/+0 * New port: databases/xrootd: Framework for fast, low latency, scalable data ac...yuri2018-08-021-0/+1 * pg_similarity is an extension to support similarity queries on PostgreSQL. Themiwi2018-07-281-0/+1 * - Copy databases/mongodb34-tools -> databases/mongodb36-toolsmiwi2018-07-281-0/+1 * new port: databases/dbixx: Tiny C++ wrapper around libdbi for database and SQ...farrokhi2018-07-171-0/+1 * Bring back databases/riak portrm2018-07-101-0/+1 * New port: databases/py-aiopg: Python library for accessing PostgreSQL databas...farrokhi2018-07-071-0/+1 * New port: databases/py-aioredis: Python asycio based Redis client libraryfarrokhi2018-07-061-0/+1 * Remove expired ports:rene2018-07-031-2/+0 * Add databases/py-pgdbconn, Object-oriented layer over Psycopg2 tomat2018-07-021-0/+1 * Correctly hook py-asyncpg to the buildantoine2018-06-291-1/+1 * New Port: databases/py-asyncpg: High performance PostgreSQL Client Library fo...farrokhi2018-06-291-0/+1 * New port: databases/p5-CHI-Driver-Redispi2018-06-211-0/+1 * databases/Makefile: re-add p5-Search-InvertedIndexpi2018-06-211-0/+1 * New port: databases/p5-Scope-Container-DBIpi2018-06-211-1/+1 * New port: databases/p5-Redis-Fastpi2018-06-201-0/+1 * New port: databases/p5-CHI-Driver-Memcachedpi2018-06-201-0/+1 * databases/mariadb103-server: Add MariaDB 10.3 portbrnrd2018-06-101-0/+2 * Remove expired ports:rene2018-06-071-7/+0 * New port: databases/cayley: Open-source graph databaseyuri2018-06-041-0/+1 * New port: databases/redis_exporterpi2018-05-251-0/+1 * Add foundationdb, yet another distributed database from apple.vanilla2018-05-021-0/+1 * Remove expired ports:rene2018-05-021-1/+0 * - Add new port: databases/R-cran-RPostgreSQLtota2018-04-271-0/+1 * databases/pecl-redis: Update and split into new portjoneum2018-04-251-0/+1 * databases/redisdesktopmanager: create portswills2018-04-231-0/+1 * New port: databases/pgpool-II-37tz2018-04-181-0/+1 * Add a port of IOWOW, persistent and fast key-value database engine baseddanfe2018-04-141-0/+1 * databases/py-influxdb: Python Client for InfluxDBwg2018-04-131-0/+1 * New ports: databases/akonaditcberner2018-04-101-0/+1 * Add rubygem-dbf 3.1.1sunpoet2018-04-081-0/+1 * Add rubygem-flipper-active_record013 0.13.0 (copied from rubygem-flipper-acti...sunpoet2018-04-061-0/+1 * New ports required for gitlab update to 10.5.x.mfechner2018-03-261-0/+1 * Remove expired ports:rene2018-03-211-1/+0 * Move databases/akonadi to databases/akonadi-kde4tcberner2018-03-211-1/+1 * New port: databases/go-carbonpi2018-03-201-0/+1 * New port: databases/py-pum: Postgres upgrade manageryuri2018-03-191-0/+1 * New port: databases/pgsanitytobik2018-03-181-0/+1 * Remove databases/php-memcachedsunpoet2018-03-111-1/+0 * Introduce PHP flavors.mat2018-03-091-4/+2 * SQLAlchemy integration with the marshmallow (de)serialization library.feld2018-03-081-0/+1 * Add new port datagbases/pgmetricsgirgen2018-03-061-0/+1 * New port: databases/usql: Universal command-line interface for SQL databasesyuri2018-03-041-0/+1 * Add php7-tarantool 0.3.0 (copied from php5-tarantool)sunpoet2018-03-011-0/+1 * Remove expired databases/rubygem-flipper-active_record010sunpoet2018-02-281-1/+0 * Add rubygem-pg0 0.21.0 (copied from rubygem-pg)sunpoet2018-02-211-0/+1 * databases/rubygem-seed-fu236: Resurrect port in version 2.3.6tz2018-02-151-0/+1 * databases/rubygem-redis-namespace15: Resurrect port in version 1.5.3tz2018-02-151-0/+1 * databases/rubygem-flipper-active_record011: Resurrect port in version 0.11.0tz2018-02-151-0/+1 * databases/mariadb-connector-odbc: Properly add to portsbrnrd2018-02-151-0/+1 * Remove two ports that were only for PostgreSQL 9.2:rene2018-02-111-2/+0 * Removed expired postgresql92 ports.rene2018-02-111-7/+0 * Remove expired ports:rene2018-02-111-1/+0 * New port: databases/arangodb33: ArangoDB, branch for 3.3.X series, version 3.3.3yuri2018-02-081-0/+1 * re-add databases/mongodb36 - it was not repocopiedlifanov2018-02-061-0/+1 * Remove expired port:rene2018-02-011-1/+0 * Add py-sqlalchemy12 1.2.1 (copied from py-sqlalchemy11)sunpoet2018-01-251-0/+1 * New port: databases/py-pglite: Light PostgreSQL: use PostgreSQL as an SQLite ...yuri2018-01-161-0/+1 * Remove mistakenly added portgirgen2018-01-131-1/+0 * Update postgresql-libpqxx to latest version 6girgen2018-01-131-0/+2 * Revert r457783, it was not added properly.mat2018-01-041-1/+0 * Add rubygem-redis3 3.3.5 (copied from rubygem-redis)sunpoet2018-01-021-0/+1 * New port: databases/py-python-arango: Python driver for ArangoDByuri2018-01-021-0/+1 * add new port: MongoDB 3.6.0lifanov2018-01-021-0/+1 * Add rubygem-arel8 8.0.0 (copied from rubygem-arel)sunpoet2017-12-171-0/+1 * Add new port postgis24 for v2.4.xrodrigo2017-12-171-0/+1 * databases/py-sqlparse020: create portswills2017-12-121-0/+1 * Add php72-memcache 3.0.8 (copied from php71-memcache)sunpoet2017-12-071-0/+1 * Convert Python ports to FLAVORS.mat2017-11-301-10/+0 * New port: databases/pspg: Tabular data pager designed to be used with psqlyuri2017-11-231-0/+1 * Repo copy databases/rubygem-flipper-active_record and devel/rubygem-flippertz2017-11-221-0/+1 * Hook ldb12 and ldb13 to the buildantoine2017-11-221-0/+2 * new port: databases/arangodb32lifanov2017-11-211-0/+1 * Remove databases/grass6 in favor of the existing databases/grass7.gerald2017-11-191-1/+0 * Remove duplicate portantoine2017-11-171-1/+0 * New Port: lua-resty-redis - for accessing redis from nginx luajoneum2017-11-171-0/+1 * Add PHP 7.2 RC6tz2017-11-161-0/+14 * Removing expired port:rene2017-11-131-1/+0 * Remove expired port:rene2017-11-111-1/+0 * Remove expired ports:rene2017-11-111-1/+0 * Remove expired ports:rene2017-11-031-2/+0 * Under Python2, this package forks both Python 2.7's pickle andfeld2017-10-131-0/+1 * New port databases/zabbix34-libzbxpgsql: PostgreSQL monitoring module for zab...dbaio2017-10-121-0/+1 * Add lazperf to the ports treegirgen2017-09-271-0/+1 * Remove non functionnal port.mat2017-09-271-1/+0 * Unhook pointcloudadamw2017-09-271-1/+1 * Add pointcloud to the ports treegirgen2017-09-271-0/+1 * [NEW] databases/pgroonga: Open-source fulltext search engine for PostGRESQLbofh2017-09-201-0/+1 * [NEW] databases/mroonga: Open-source fulltext search engine for MySQLbofh2017-09-201-0/+1 * Add py-lmdb 0.93, python bindings for LMDB.vanilla2017-09-111-0/+1 * Sort categories Makefiles properly.mat2017-09-111-2/+2 * New port, databases/pecl-rrd1: Copied from databases/pecl-rrd, so thatjrm2017-09-071-0/+1 * Remove Python 3.3 and related ports, it expired today:rene2017-09-031-2/+0 * New port databases/zabbix32-libzbxpgsql: PostgreSQL monitoring module for zab...dbaio2017-08-271-0/+1 * New port databases/zabbix22-libzbxpgsql: PostgreSQL monitoring module for zab...dbaio2017-08-271-0/+1 * databases/libzbxpgsql: Update to 1.1.0, Rename to databases/zabbix3-libzbxpgsqldbaio2017-08-271-1/+1 * New port: databases/rubygem-peek-pgtz2017-08-241-0/+1 * New port: databases/rubygem-peek-mysql2tz2017-08-241-0/+1 * databases/sqlitebrowser: update to 3.10.0; remove sqlitebrowser-qt5swills2017-08-221-1/+0 * CockroachDB is a distributed SQL database built on a transactionalkrion2017-08-211-0/+1 * Fix INDEXantoine2017-08-171-1/+1 * New port: databases/postgres-xlpi2017-08-171-0/+1 * New port databases/puppetdb-terminus5romain2017-08-121-0/+1 * New port databases/puppetdb5romain2017-08-121-0/+1 * New port: databases/pg_partmanpi2017-08-111-0/+1 * Add PostgreSQL-10 to the ports treegirgen2017-08-111-0/+8 * New port: databases/pgloader3tz2017-08-071-0/+1 * New port: databases/grass7pi2017-07-301-1/+2 * New port: databases/pg_dirtyreadtz2017-07-271-0/+1 * databases/rubygem-active_model_serializers: Conventions-based JSONjrm2017-07-261-0/+1 * databases/rubygem-mario-redis-lock: Ruby distributed lock using Redis, with anjrm2017-07-261-0/+1 * databases/py-odbc: Update to 4.0.17, Rename to databases/py-pyodbcdbaio2017-07-191-1/+1 * New port: databases/postgresql-orafcetz2017-07-171-0/+1 * New port: databases/postgresql-zhparsertz2017-07-171-0/+1 * New port: databases/postgresql-tds_fdwtz2017-07-14