aboutsummaryrefslogtreecommitdiffstats
path: root/x11/yelp/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-21 02:06:55 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-21 02:06:55 +0800
commitd129117f30e9b541cfe198785a7bc6b1007985a3 (patch)
tree1d4b497414ae4d74aef1a9e61622d22869f7fc17 /x11/yelp/Makefile
parent4ea9680d7ef5be9705430fbb0e403bd88530810f (diff)
downloadfreebsd-ports-gnome-d129117f30e9b541cfe198785a7bc6b1007985a3.tar.gz
freebsd-ports-gnome-d129117f30e9b541cfe198785a7bc6b1007985a3.tar.zst
freebsd-ports-gnome-d129117f30e9b541cfe198785a7bc6b1007985a3.zip
Add yelp 0.7, a help browser for GNOME 2.0 desktop.
Diffstat (limited to 'x11/yelp/Makefile')
-rw-r--r--x11/yelp/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
new file mode 100644
index 000000000000..84e0e07e744d
--- /dev/null
+++ b/x11/yelp/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: yelp
+# Date created: 18 May 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yelp
+PORTVERSION= 0.7
+CATEGORIES= x11 gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gtkhtml-2.0:${PORTSDIR}/www/libgtkhtml
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>