aboutsummaryrefslogtreecommitdiffstats
path: root/x11/yelp
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-11-20 23:37:08 +0800
committerkwm <kwm@FreeBSD.org>2010-11-20 23:37:08 +0800
commit3d272740920a1868e8acfed76d6e4c67c331e101 (patch)
tree2a5c0b3f83feeff6b7818d6af84084a526182651 /x11/yelp
parent16773b885888858d80db86065d33dcf723459cbd (diff)
downloadfreebsd-ports-gnome-3d272740920a1868e8acfed76d6e4c67c331e101.tar.gz
freebsd-ports-gnome-3d272740920a1868e8acfed76d6e4c67c331e101.tar.zst
freebsd-ports-gnome-3d272740920a1868e8acfed76d6e4c67c331e101.zip
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/ This will be the last release of the GNOME 2.x series, mainly a bugfix and bridge release to the first release of the GNOME 3.x series. This release features commits by avl, marcus, mezz and myself. The FreeBSD GNOME Team would like to thank the following contributors and testers for there help with this release: Zane C.B. <vvelox@vvelox.net> romain@ Olaf Seibert <O.Seibert@cs.ru.nl> DomiX Bapt <baptiste.daroussin@gmail.com> jsa@ miwi@ Sergio de Almeida Lenzi <lenzi.sergio@gmail.com> Maxim Samsonov <xors@mne.ru> Kris Moore And pav@ for 2 exp-runs PR: ports/152255 ports/143260 ports/141033 ports/149629 ports/150350 ports/151523 With hat: gnome@
Diffstat (limited to 'x11/yelp')
-rw-r--r--x11/yelp/Makefile8
-rw-r--r--x11/yelp/distinfo6
-rw-r--r--x11/yelp/files/patch-src_yelp-window.c37
-rw-r--r--x11/yelp/pkg-plist3
4 files changed, 48 insertions, 6 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index bbd19f347fb2..df720e976ec5 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -3,12 +3,12 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/yelp/Makefile,v 1.154 2010/04/27 13:32:17 kwm Exp $
+# $MCom: ports/x11/yelp/Makefile,v 1.164 2010/10/18 13:37:34 kwm Exp $
#
PORTNAME= yelp
-PORTVERSION= 2.30.1
-PORTREVISION= 2
+PORTVERSION= 2.30.2
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,6 +20,8 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
rarian.0:${PORTSDIR}/textproc/rarian
+CONFLICTS= yelp-2.31.*
+
USE_GECKO= libxul
USE_GETTEXT= yes
USE_BZIP2= yes
diff --git a/x11/yelp/distinfo b/x11/yelp/distinfo
index ef7c6f151f27..0d552a50699d 100644
--- a/x11/yelp/distinfo
+++ b/x11/yelp/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/yelp-2.30.1.tar.bz2) = afd638cdaea1fcb9821ece88b819a022
-SHA256 (gnome2/yelp-2.30.1.tar.bz2) = 4b453e994f8e57bc5c4637dba2c315536f30e90741b74b0bee218cbb436eb20c
-SIZE (gnome2/yelp-2.30.1.tar.bz2) = 1139961
+MD5 (gnome2/yelp-2.30.2.tar.bz2) = d745dafd0c134e726511894621d9b050
+SHA256 (gnome2/yelp-2.30.2.tar.bz2) = 5f8c35847bdae654e21cbba66865d6b582d9fc80a059ad29081bb87e146bb165
+SIZE (gnome2/yelp-2.30.2.tar.bz2) = 1159521
diff --git a/x11/yelp/files/patch-src_yelp-window.c b/x11/yelp/files/patch-src_yelp-window.c
new file mode 100644
index 000000000000..37acdfcc501a
--- /dev/null
+++ b/x11/yelp/files/patch-src_yelp-window.c
@@ -0,0 +1,37 @@
+--- src/yelp-window.c.orig 2010-10-16 23:06:05.000000000 +0400
++++ src/yelp-window.c 2010-10-17 03:58:57.000000000 +0400
+@@ -1555,28 +1555,26 @@
+
+ gtk_label_set_mnemonic_widget (GTK_LABEL (label), priv->find_entry);
+
+- box = gtk_hbox_new (FALSE, 0);
+ arrow = gtk_arrow_new (GTK_ARROW_LEFT, GTK_SHADOW_NONE);
+ label = gtk_label_new_with_mnemonic (_("Find _Previous"));
+- gtk_box_pack_start (GTK_BOX (box), arrow, FALSE, FALSE, 0);
+- gtk_box_pack_start (GTK_BOX (box), label, TRUE, TRUE, 0);
+- priv->find_prev = gtk_tool_button_new (box, NULL);
++ priv->find_prev = gtk_tool_button_new (arrow, NULL);
++ gtk_tool_button_set_label_widget (GTK_TOOL_BUTTON (priv->find_prev), label);
+ g_signal_connect (priv->find_prev,
+ "clicked",
+ G_CALLBACK (window_find_clicked_cb),
+ window);
++ gtk_tool_item_set_is_important (priv->find_prev, TRUE);
+ gtk_toolbar_insert (GTK_TOOLBAR (find_bar), priv->find_prev, -1);
+
+- box = gtk_hbox_new (FALSE, 0);
+ arrow = gtk_arrow_new (GTK_ARROW_RIGHT, GTK_SHADOW_NONE);
+ label = gtk_label_new_with_mnemonic (_("Find _Next"));
+- gtk_box_pack_start (GTK_BOX (box), arrow, FALSE, FALSE, 0);
+- gtk_box_pack_start (GTK_BOX (box), label, TRUE, TRUE, 0);
+- priv->find_next = gtk_tool_button_new (box, NULL);
++ priv->find_next = gtk_tool_button_new (arrow, NULL);
++ gtk_tool_button_set_label_widget (GTK_TOOL_BUTTON (priv->find_next), label);
+ g_signal_connect (priv->find_next,
+ "clicked",
+ G_CALLBACK (window_find_clicked_cb),
+ window);
++ gtk_tool_item_set_is_important (priv->find_next, TRUE);
+ gtk_toolbar_insert (GTK_TOOLBAR (find_bar), priv->find_next, -1);
+
+ priv->find_sep = gtk_separator_tool_item_new ();
diff --git a/x11/yelp/pkg-plist b/x11/yelp/pkg-plist
index 903c7d3c5d98..4321292b2453 100644
--- a/x11/yelp/pkg-plist
+++ b/x11/yelp/pkg-plist
@@ -47,6 +47,7 @@ share/locale/is/LC_MESSAGES/yelp.mo
share/locale/it/LC_MESSAGES/yelp.mo
share/locale/ja/LC_MESSAGES/yelp.mo
share/locale/ka/LC_MESSAGES/yelp.mo
+share/locale/kk/LC_MESSAGES/yelp.mo
share/locale/kn/LC_MESSAGES/yelp.mo
share/locale/ko/LC_MESSAGES/yelp.mo
share/locale/ks/LC_MESSAGES/yelp.mo
@@ -178,6 +179,8 @@ share/locale/zu/LC_MESSAGES/yelp.mo
@dirrmtry share/locale/ku
@dirrmtry share/locale/ks/LC_MESSAGES
@dirrmtry share/locale/ks
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
@dirrmtry share/locale/fur/LC_MESSAGES
@dirrmtry share/locale/fur
@dirrmtry share/locale/en@shaw/LC_MESSAGES