aboutsummaryrefslogtreecommitdiffstats
path: root/x11/yelp
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-05-03 08:26:19 +0800
committermarcus <marcus@FreeBSD.org>2006-05-03 08:26:19 +0800
commiteb10490afe4414afaf156eb86882f6dfca5bb09b (patch)
tree2762755e18f743ac2d692094a57453c8cbedcf05 /x11/yelp
parent768f526847ba5f3f4bead265f30332fefd07ef92 (diff)
downloadfreebsd-ports-gnome-eb10490afe4414afaf156eb86882f6dfca5bb09b.tar.gz
freebsd-ports-gnome-eb10490afe4414afaf156eb86882f6dfca5bb09b.tar.zst
freebsd-ports-gnome-eb10490afe4414afaf156eb86882f6dfca5bb09b.zip
Fix a crash that can be triggered when searching through man pages.
Reported by: Sean McNeil <sean@mcneil.com>
Diffstat (limited to 'x11/yelp')
-rw-r--r--x11/yelp/Makefile1
-rw-r--r--x11/yelp/files/patch-src_yelp-search-pager.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index dfbba72b23bc..bc56bda01bb6 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -8,6 +8,7 @@
PORTNAME= yelp
PORTVERSION= 2.14.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/x11/yelp/files/patch-src_yelp-search-pager.c b/x11/yelp/files/patch-src_yelp-search-pager.c
new file mode 100644
index 000000000000..81c275b4d422
--- /dev/null
+++ b/x11/yelp/files/patch-src_yelp-search-pager.c
@@ -0,0 +1,11 @@
+--- src/yelp-search-pager.c.orig Tue May 2 19:10:03 2006
++++ src/yelp-search-pager.c Tue May 2 18:59:36 2006
+@@ -1413,7 +1413,7 @@ process_man_result (YelpSearchPager *pag
+ after = strstr (before, "(");
+ tmp = after;
+
+- while (!g_ascii_isspace(*tmp))
++ while (g_ascii_isspace(*tmp))
+ tmp--;
+
+ title = g_strndup (before, tmp-before);