aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-08-03 14:53:12 +0800
committermarcus <marcus@FreeBSD.org>2008-08-03 14:53:12 +0800
commit13fdfeb0ffccad15f0251ed6aaeebd38dd063206 (patch)
treed8b26d089e589c5aa5a9a50a3bfb7b9701d53973 /x11
parent49900ae80fd68740d968fada1461b0a0220ed229 (diff)
downloadfreebsd-ports-gnome-13fdfeb0ffccad15f0251ed6aaeebd38dd063206.tar.gz
freebsd-ports-gnome-13fdfeb0ffccad15f0251ed6aaeebd38dd063206.tar.zst
freebsd-ports-gnome-13fdfeb0ffccad15f0251ed6aaeebd38dd063206.zip
* Mention dependency of KEYRING on PAM in its description
* Force PAM when KEYRING is enabled * Memove .warning that confuses portupgrade PR: 126114 Submitted by: Marcin Wisnicki <mwisnicki+freebsd@gmail.com>
Diffstat (limited to 'x11')
-rw-r--r--x11/xscreensaver-gnome/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index bb0b4bbfb788..f0b7ae6ccfa7 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS?= PAM "Pluggable Authentication Module support" on \
- KEYRING "Enable GnomeKeyring/PAM integration" on \
+ KEYRING "Enable GnomeKeyring integration (needs PAM)" on \
ALL_FORTUNES "Enable support for all fortunes" off \
SETUID_HACKS "Install sonar hack suid so it can ping" off
@@ -90,22 +90,20 @@ MAN6?= anemone.6 anemotaxis.6 antinspect.6 antmaze.6 antspotlight.6 \
CONFIGURE_ARGS+= --with-fortune="/usr/games/fortune -sa"
.endif
-.if defined(WITH_PAM)
+.if defined(WITH_PAM) || defined(WITH_KEYRING)
CONFIGURE_ARGS+= --with-pam
PLIST_SUB+= PAM=""
+.else
+CONFIGURE_ARGS+= --without-pam
+PLIST_SUB+= PAM="@comment "
+.endif
+
.if defined(WITH_KEYRING)
SUB_LIST+= PAM_KEYRING=
RUN_DEPENDS+= ${LOCALBASE}/lib/pam_gnome_keyring.so:${PORTSDIR}/security/gnome-keyring
.else
SUB_LIST+= PAM_KEYRING=\#
.endif
-.else
-CONFIGURE_ARGS+= --without-pam
-PLIST_SUB+= PAM="@comment "
-.if defined(WITH_KEYRING)
-.warning Option KEYRING needs PAM, but PAM is disabled.
-.endif
-.endif
.if defined(WITH_SETUID_HACKS)
CONFIGURE_ARGS+= --with-setuid-hacks