aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-10-11 21:38:33 +0800
committerbf <bf@FreeBSD.org>2011-10-11 21:38:33 +0800
commit1903c1f1c51869829753776b961128dbe8ddbb50 (patch)
treed3a3862bff93706e78d279fb24bd879b487380cb /x11
parente00bf16ef1ac22bcae00caa1890da55a4fd0079c (diff)
downloadfreebsd-ports-gnome-1903c1f1c51869829753776b961128dbe8ddbb50.tar.gz
freebsd-ports-gnome-1903c1f1c51869829753776b961128dbe8ddbb50.tar.zst
freebsd-ports-gnome-1903c1f1c51869829753776b961128dbe8ddbb50.zip
fix build with cups
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs3/Makefile3
-rw-r--r--x11/kdelibs3/files/patch-kdeprint__cups__cupsdconf2__cups-util.c10
2 files changed, 11 insertions, 2 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index eecb14c1cc96..07e38117ce67 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -45,7 +45,6 @@ PKGNAMESUFFIX= -nocups
CONFIGURE_ARGS+=--disable-cups
PLIST= ${.CURDIR}/../kdelibs3-nocups/pkg-plist
.else
-BROKEN= does not build
CONFLICTS+= kdelibs-nocups-[0-9]*
LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-client
.endif
diff --git a/x11/kdelibs3/files/patch-kdeprint__cups__cupsdconf2__cups-util.c b/x11/kdelibs3/files/patch-kdeprint__cups__cupsdconf2__cups-util.c
new file mode 100644
index 000000000000..1f2d38c7aee7
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdeprint__cups__cupsdconf2__cups-util.c
@@ -0,0 +1,10 @@
+--- kdeprint/cups/cupsdconf2/cups-util.c.orig 2007-10-08 05:52:10.000000000 -0400
++++ kdeprint/cups/cupsdconf2/cups-util.c 2011-10-09 18:03:23.000000000 -0400
+@@ -2,6 +2,7 @@
+ #include <cups/http.h>
+ #include <cups/cups.h>
+ #include <stdlib.h>
++#include <stdio.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <unistd.h>