aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-09-20 14:38:19 +0800
committerijliao <ijliao@FreeBSD.org>2002-09-20 14:38:19 +0800
commit1b326f3ac4d80e51f3e3de07da88da37b55af29d (patch)
treef8446df57c70a89e7a15e94054f48a1fe7824f12 /x11
parentd7cff92c2705c82c77cb4de5f86946cb8c8313ee (diff)
downloadfreebsd-ports-gnome-1b326f3ac4d80e51f3e3de07da88da37b55af29d.tar.gz
freebsd-ports-gnome-1b326f3ac4d80e51f3e3de07da88da37b55af29d.tar.zst
freebsd-ports-gnome-1b326f3ac4d80e51f3e3de07da88da37b55af29d.zip
- Support CFLAGS/CXXFLAGS properly
- ECHO -> ECHO_MSG PR: 42894 Submitted by: Ports Fury
Diffstat (limited to 'x11')
-rw-r--r--x11/xbindkeys/Makefile35
1 files changed, 17 insertions, 18 deletions
diff --git a/x11/xbindkeys/Makefile b/x11/xbindkeys/Makefile
index 0c0950d109f8..257bf7e60b05 100644
--- a/x11/xbindkeys/Makefile
+++ b/x11/xbindkeys/Makefile
@@ -8,45 +8,44 @@
PORTNAME= xbindkeys
PORTVERSION= 1.5.5
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://hocwp.free.fr/xbindkeys/
MAINTAINER= ports@FreeBSD.org
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
INSTALL_TARGET= install-binPROGRAMS
+MAN1= xbindkeys.1
+
.if defined(WITH_GUI)
-RUN_DEPENDS= wish:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+MAN1+= xbindkeys_show.1
PLIST_SUB+= WITH_GUI=""
SCRIPTS_ENV+= WITH_GUI="YES"
.else
PLIST_SUB+= WITH_GUI="@comment "
.endif
-USE_XLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${X11BASE}/include"
-
-MAN1= xbindkeys.1
-.if defined(WITH_GUI)
-MAN1+= xbindkeys_show.1
-.endif
-
-pre-fetch:
+pre-everything::
.if !defined(WITH_GUI)
- @${ECHO} ""
- @${ECHO} " Define WITH_GUI to install xbindkeys_show (requires Tk)"
- @${ECHO} ""
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GUI to install xbindkeys_show (requires Tk)"
+ @${ECHO_MSG} ""
.endif
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/xbindkeysrc ${EXAMPLESDIR}
-.endif
${INSTALL_MAN} ${WRKSRC}/xbindkeys.1 ${MANPREFIX}/man/man1
.if defined(WITH_GUI)
${INSTALL_MAN} ${WRKSRC}/xbindkeys_show.1 ${MANPREFIX}/man/man1
.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xbindkeysrc ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>