aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-09-07 03:22:27 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-09-07 03:22:27 +0800
commit5e5389e65f21c10c9a7cb825c9a74939bd3aed2d (patch)
treef0df9b099d61670c99796341ed8742eabfb55c72 /x11
parent4601f75c571234dc3eb2270965224e78273e91a2 (diff)
downloadfreebsd-ports-gnome-5e5389e65f21c10c9a7cb825c9a74939bd3aed2d.tar.gz
freebsd-ports-gnome-5e5389e65f21c10c9a7cb825c9a74939bd3aed2d.tar.zst
freebsd-ports-gnome-5e5389e65f21c10c9a7cb825c9a74939bd3aed2d.zip
Add terminal.app, a terminal Emulator for GNUstep.
PR: ports/102660 Submitted by: gurkan at linuks.mine.nu
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/terminal.app/Makefile35
-rw-r--r--x11/terminal.app/distinfo3
-rw-r--r--x11/terminal.app/pkg-descr5
-rw-r--r--x11/terminal.app/pkg-plist31
5 files changed, 75 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 8ad35892dfd1..d69a40e885a9 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -205,6 +205,7 @@
SUBDIR += startup-notification
SUBDIR += sxpc
SUBDIR += temperature.app
+ SUBDIR += terminal.app
SUBDIR += thinglaunch
SUBDIR += tilda
SUBDIR += tkXwin
diff --git a/x11/terminal.app/Makefile b/x11/terminal.app/Makefile
new file mode 100644
index 000000000000..669042a90a26
--- /dev/null
+++ b/x11/terminal.app/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: terminal.app
+# Date created: 28 Aug 2006
+# Whom: gurkan@linuks.mine.nu
+#
+# $FreeBSD$
+#
+
+PORTNAME= terminal.app
+PORTVERSION= 0.9.4
+DISTVERSIONSUFFIX= +cvs20051125.orig
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${DISTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= gurkan@linuks.mine.nu
+COMMENT= Terminal Emulator for GNUstep
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+
+MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${PORTNAME:C/\.app//}-${DISTVERSION}${DISTVERSIONSUFFIX:C/\.orig//}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/terminal.app/distinfo b/x11/terminal.app/distinfo
new file mode 100644
index 000000000000..d990bf22f023
--- /dev/null
+++ b/x11/terminal.app/distinfo
@@ -0,0 +1,3 @@
+MD5 (terminal.app_0.9.4+cvs20051125.orig.tar.gz) = e59300f725d1cad5596971792f2c4965
+SHA256 (terminal.app_0.9.4+cvs20051125.orig.tar.gz) = 05a560cfd614fb5d01afee83f5706303d0a92630777dd7acc60fe1c5cf3ed470
+SIZE (terminal.app_0.9.4+cvs20051125.orig.tar.gz) = 71656
diff --git a/x11/terminal.app/pkg-descr b/x11/terminal.app/pkg-descr
new file mode 100644
index 000000000000..6b99b280e3e8
--- /dev/null
+++ b/x11/terminal.app/pkg-descr
@@ -0,0 +1,5 @@
+Terminal provides terminal emulation in a GNUstep environment. It gives
+colorized terminals with configurable fonts, and also allows users to configure
+shell utilities as GNUstep services.
+
+WWW: http://www.nongnu.org/backbone/
diff --git a/x11/terminal.app/pkg-plist b/x11/terminal.app/pkg-plist
new file mode 100644
index 000000000000..9a68f73eb0eb
--- /dev/null
+++ b/x11/terminal.app/pkg-plist
@@ -0,0 +1,31 @@
+System/Applications/Terminal.app/Resources/DefaultTerminalServices.svcs
+System/Applications/Terminal.app/Resources/English.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/French.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/German.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/Hungarian.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/Info-gnustep.plist
+System/Applications/Terminal.app/Resources/Norwegian.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/Russian.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/Spanish.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/Swedish.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/Terminal.desktop
+System/Applications/Terminal.app/Resources/Terminal.tiff
+System/Applications/Terminal.app/Resources/Turkish.lproj/Localizable.strings
+System/Applications/Terminal.app/Resources/cursor_filled.tiff
+System/Applications/Terminal.app/Resources/cursor_inverted.tiff
+System/Applications/Terminal.app/Resources/cursor_line.tiff
+System/Applications/Terminal.app/Resources/cursor_stroked.tiff
+System/Applications/Terminal.app/Terminal
+System/Applications/Terminal.app/library_paths.openapp
+System/Applications/Terminal.app/stamp.make
+@dirrm System/Applications/Terminal.app/Resources/Turkish.lproj
+@dirrm System/Applications/Terminal.app/Resources/Swedish.lproj
+@dirrm System/Applications/Terminal.app/Resources/Spanish.lproj
+@dirrm System/Applications/Terminal.app/Resources/Russian.lproj
+@dirrm System/Applications/Terminal.app/Resources/Norwegian.lproj
+@dirrm System/Applications/Terminal.app/Resources/Hungarian.lproj
+@dirrm System/Applications/Terminal.app/Resources/German.lproj
+@dirrm System/Applications/Terminal.app/Resources/French.lproj
+@dirrm System/Applications/Terminal.app/Resources/English.lproj
+@dirrm System/Applications/Terminal.app/Resources
+@dirrm System/Applications/Terminal.app