aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-12-24 18:55:36 +0800
committerreg <reg@FreeBSD.org>2000-12-24 18:55:36 +0800
commit68dc13e3989f3b452327a9230c196282351dc525 (patch)
treed534ecde34f807dc5faa2c2068353fdf3593aee2 /x11
parent9a8c72696cf10dd3d74745da112a986805ee07dc (diff)
downloadfreebsd-ports-gnome-68dc13e3989f3b452327a9230c196282351dc525.tar.gz
freebsd-ports-gnome-68dc13e3989f3b452327a9230c196282351dc525.tar.zst
freebsd-ports-gnome-68dc13e3989f3b452327a9230c196282351dc525.zip
Add a security alert dialog and remove FORBIDDEN.
Diffstat (limited to 'x11')
-rw-r--r--x11/XFree86-aoutlibs/Makefile11
-rw-r--r--x11/XFree86-aoutlibs/pkg-install19
2 files changed, 27 insertions, 3 deletions
diff --git a/x11/XFree86-aoutlibs/Makefile b/x11/XFree86-aoutlibs/Makefile
index 3db94b1314c6..9f0ba36c153e 100644
--- a/x11/XFree86-aoutlibs/Makefile
+++ b/x11/XFree86-aoutlibs/Makefile
@@ -12,8 +12,6 @@ MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/3.3.3/binaries/FreeBSD-2.2.x/
DISTNAME= Xbin
EXTRACT_SUFX= .tgz
-FORBIDDEN= "Remote denial of service and buffer overflow vulnerabilities"
-
MAINTAINER= reg@FreeBSD.org
ONLY_FOR_ARCHS= i386
@@ -24,6 +22,13 @@ PORTOBJFORMAT= aout
USE_X_PREFIX= yes
+.include <bsd.port.pre.mk>
+
+pre-extract:
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+ @${SH} ${PKGINSTALL} foo PRE-INSTALL || ${FALSE}
+.endif
+
pre-configure:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
@@ -36,4 +41,4 @@ do-install:
done
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib/aout
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/XFree86-aoutlibs/pkg-install b/x11/XFree86-aoutlibs/pkg-install
new file mode 100644
index 000000000000..dba6ec91ef37
--- /dev/null
+++ b/x11/XFree86-aoutlibs/pkg-install
@@ -0,0 +1,19 @@
+#!/bin/sh
+TTY=/dev/tty
+
+case $2 in
+ POST-INSTALL)
+ ;;
+ PRE-INSTALL)
+ if dialog --yesno "This port installs old X libraries, which contain possible security exploits. If security is a concern for you, then you can install fresh a.out libraries from the XFree86 3.3.6 port, although these might not work with older a.out binaries." 16 65 < ${TTY} >${TTY} 2>&1; then
+ exit 0
+ else
+ exit 1
+ fi
+ ;;
+ *)
+ echo "Unexpected argument $2!"
+ exit 1
+ ;;
+esac
+exit 0