aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-08-12 14:29:36 +0800
committerasami <asami@FreeBSD.org>1998-08-12 14:29:36 +0800
commit8a7e60c34586bb5267b5568f4aaf008466293240 (patch)
tree0eb60edc356664a1c6e82fcb4123098fa93c8c33 /x11
parentf76f8647163274d25404da963254d945f45f725a (diff)
downloadfreebsd-ports-gnome-8a7e60c34586bb5267b5568f4aaf008466293240.tar.gz
freebsd-ports-gnome-8a7e60c34586bb5267b5568f4aaf008466293240.tar.zst
freebsd-ports-gnome-8a7e60c34586bb5267b5568f4aaf008466293240.zip
Replace qt dependencies with USE_QT.
(Also, net/licq/Makefile: No need to define both HAS_CONFIGURE and GNU_CONFIGURE)
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-baseapps/Makefile7
-rw-r--r--x11/kde4-runtime/Makefile7
-rw-r--r--x11/kde4-workspace/Makefile7
-rw-r--r--x11/kdebase11/Makefile7
-rw-r--r--x11/kdebase2/Makefile7
-rw-r--r--x11/kdebase3/Makefile7
-rw-r--r--x11/kdebase4-runtime/Makefile7
-rw-r--r--x11/kdebase4-workspace/Makefile7
-rw-r--r--x11/kdebase4/Makefile7
-rw-r--r--x11/kdelibs11/Makefile7
-rw-r--r--x11/kdelibs2/Makefile7
-rw-r--r--x11/kdelibs3/Makefile7
-rw-r--r--x11/kdelibs4/Makefile7
-rw-r--r--x11/kworldwatch/Makefile7
14 files changed, 42 insertions, 56 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kdebase11/Makefile b/x11/kdebase11/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kdebase11/Makefile
+++ b/x11/kdebase11/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kdebase2/Makefile b/x11/kdebase2/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kdebase2/Makefile
+++ b/x11/kdebase2/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index ec50c2dd565d..b25acfec9bec 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.15 1998/07/23 20:52:03 se Exp $
+# $Id: Makefile,v 1.16 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdebase-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -24,6 +22,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
kfm\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/x11/kdelibs11/Makefile b/x11/kdelibs11/Makefile
index a15c2a99e8b6..5c7d8905157f 100644
--- a/x11/kdelibs11/Makefile
+++ b/x11/kdelibs11/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:52:04 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdelibs-1.0
@@ -13,11 +13,10 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--x-inc=$(X11BASE)/include" \
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index a15c2a99e8b6..5c7d8905157f 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:52:04 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdelibs-1.0
@@ -13,11 +13,10 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--x-inc=$(X11BASE)/include" \
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index a15c2a99e8b6..5c7d8905157f 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:52:04 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdelibs-1.0
@@ -13,11 +13,10 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--x-inc=$(X11BASE)/include" \
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index a15c2a99e8b6..5c7d8905157f 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:52:04 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kdelibs-1.0
@@ -13,11 +13,10 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--x-inc=$(X11BASE)/include" \
diff --git a/x11/kworldwatch/Makefile b/x11/kworldwatch/Makefile
index ba7650618bed..035b189cf8b6 100644
--- a/x11/kworldwatch/Makefile
+++ b/x11/kworldwatch/Makefile
@@ -3,7 +3,7 @@
# Date created: 12 July 1998
# Whom: Marc G. Fournier <scrappy@freebsd.org>
#
-# $Id: Makefile,v 1.2 1998/07/25 12:42:49 asami Exp $
+# $Id: Makefile,v 1.3 1998/08/07 23:56:54 asami Exp $
#
DISTNAME= kworldwatch-0.6
@@ -14,14 +14,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= scrappy@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt
-LIB_DEPENDS= qt\\.1\\.3[1-9]:${PORTSDIR}/x11-toolkits/qt \
- kdecore\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+LIB_DEPENDS= kdecore\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.0\\.9[1-9]:${PORTSDIR}/x11/kdelibs \
kfm\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs
BROKEN= upgrade
+USE_QT= yes
HAS_CONFIGURE= yes
.include <bsd.port.mk>