aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
commit971087c2b4d6b0b917e3fac3ac1334b04f7c9907 (patch)
tree7181a8316bbb1b7be4386d9173b3c6ace07025da /x11
parent0cc85c09b55a7d94ca1d7c16c8eedae091f2840c (diff)
downloadfreebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.gz
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.zst
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Diffstat (limited to 'x11')
-rw-r--r--x11/gxset/Makefile4
-rw-r--r--x11/wmappl/Makefile10
-rw-r--r--x11/wmappl/files/patch-Makefile8
3 files changed, 12 insertions, 10 deletions
diff --git a/x11/gxset/Makefile b/x11/gxset/Makefile
index 4a4629f868c5..cad3bd1302ce 100644
--- a/x11/gxset/Makefile
+++ b/x11/gxset/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gxset
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://ftp.seindal.dk/pub/rene/ \
${MASTER_SITE_LOCAL}
@@ -15,8 +16,7 @@ MASTER_SITE_SUBDIR= petef
MAINTAINER= bms@spc.org
COMMENT= GTK frontend for xset(1)
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_XPM= yes
diff --git a/x11/wmappl/Makefile b/x11/wmappl/Makefile
index 155ccf3a03ba..43eaebed5cba 100644
--- a/x11/wmappl/Makefile
+++ b/x11/wmappl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wmappl
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= x11 windowmaker
MASTER_SITES= http://www.upl.cs.wisc.edu/~charkins/wmappl/
.ifndef(NOICONS)
@@ -17,11 +18,12 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= od@iclub.nsu.ru
COMMENT= An application launcher dockapp similar to wmbutton
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_XPM= yes
-MAKE_ENV= DATADIR="${DATADIR}"
+MAKE_ENV= DATADIR="${DATADIR}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
ICONSDIST= 16x16xpms.tar.gz icons_16x16.tar.gz smallicons.tar.gz
.ifndef(NOICONS)
PLIST_SUB= ICONS=""
@@ -49,7 +51,7 @@ post-install:
@${ECHO_CMD} ""
@${ECHO_CMD} "===> Installing icons to ${DATADIR} directory"
@${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${DATADIR}
+ @(cd ${WRKSRC}/icons; ${INSTALL_DATA} *.xpm ${DATADIR})
.endif
.ifndef(NOPORTDOCS)
@${ECHO_CMD} "===> Installing README as ${DOCSDIR}/README"
diff --git a/x11/wmappl/files/patch-Makefile b/x11/wmappl/files/patch-Makefile
index df195e311626..aeeeba25a84a 100644
--- a/x11/wmappl/files/patch-Makefile
+++ b/x11/wmappl/files/patch-Makefile
@@ -11,14 +11,14 @@
-DESTDIR = /usr/X11R6/bin
-ICONDIR = /usr/share/icons/wmappl
+CFLAGS += -DICONPATH=\"${DATADIR}\"
-+INCDIR = -I${X11BASE}/include/X11 -I${X11BASE}/include -I${LOCALBASE}/include
-+LIBDIR = -L${X11BASE}/lib -L${LOCALBASE}/lib
++INCDIR = -I${X11BASE}/include/X11 -I${X11BASE}/include ${CPPFLAGS}
++LIBDIR = -L${X11BASE}/lib
+DESTDIR = ${X11BASE}/bin
+ICONDIR = ${DATADIR}
# for linux
-LIBS = -lXpm -lX11 -lXext
-+LIBS = -lXpm -lX11 -lXext -lgnugetopt
++LIBS = -lXpm -lX11 -lXext
# for Solaris
# LIBS = -lXpm -lX11 -lXext -lsocket
@@ -27,7 +27,7 @@
$(TARGET): $(OBJS)
- $(CC) $(CFLAGS) -o $(TARGET) $^ $(INCDIR) $(LIBDIR) $(LIBS)
-+ $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(INCDIR) $(LDFLAGS) $(LIBDIR) $(LIBS)
clean:
for i in $(OBJS) ; do \