aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-21 21:20:24 +0800
committerwg <wg@FreeBSD.org>2013-06-21 21:20:24 +0800
commitb3a510a27f01c33b5915f5429bac498ffb763420 (patch)
treec1534965a7e352d955d87cf97065fa7f82b5d86d /x11
parent692aec3ea962400b104b969de38f61e28b0d6aa4 (diff)
downloadfreebsd-ports-gnome-b3a510a27f01c33b5915f5429bac498ffb763420.tar.gz
freebsd-ports-gnome-b3a510a27f01c33b5915f5429bac498ffb763420.tar.zst
freebsd-ports-gnome-b3a510a27f01c33b5915f5429bac498ffb763420.zip
x11/lxmenu-data: minor fixes
- Add LICENSE (GPLv2) [1] - Trim Makefile header [1] - Install docs [1] - Add DOCS to options - Pass maintainership to submitter PR: ports/179706 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'x11')
-rw-r--r--x11/lxmenu-data/Makefile31
1 files changed, 22 insertions, 9 deletions
diff --git a/x11/lxmenu-data/Makefile b/x11/lxmenu-data/Makefile
index 1bf3325706da..cc64dac4510a 100644
--- a/x11/lxmenu-data/Makefile
+++ b/x11/lxmenu-data/Makefile
@@ -1,24 +1,37 @@
-# New ports collection makefile for: lxmenu-data
-# Date created: Fri Sept 24 09:52:35 EST 2010
-# Whom: Kris Moore <kmoore@freebsd.org>
-#
+# Created by: Kris Moore <kmoore@freebsd.org>
# $FreeBSD$
-#
PORTNAME= lxmenu-data
PORTVERSION= 0.1.2
CATEGORIES= x11
-MASTER_SITES= SF/lxde/lxmenu-data%20%28desktop%20menu%29/lxmenu-data%20${PORTVERSION}
+MASTER_SITES= SF/lxde/lxmenu-data%20%28desktop%20menu%29/lxmenu-data%20${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Menu data used by lxpanel
+LICENSE= GPLv2
+
+USES= gettext
USE_XORG= x11 xmu
USE_GNOME= intltool
-USES= gettext
-GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:env
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${LOCALBASE} --sysconfdir=${LOCALBASE}/etc
USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= AUTHORS README TODO
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>