aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-24 07:08:14 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-24 07:08:14 +0800
commitbe24ac05fcaecdab43fc988a0be3459aa79379a1 (patch)
treec4d6f6578f574d26f94f31c44dcf91ee25cc7dcd /x11
parentcb40ff185d35dec0a536494d25049fe7781d6d0f (diff)
downloadfreebsd-ports-gnome-be24ac05fcaecdab43fc988a0be3459aa79379a1.tar.gz
freebsd-ports-gnome-be24ac05fcaecdab43fc988a0be3459aa79379a1.tar.zst
freebsd-ports-gnome-be24ac05fcaecdab43fc988a0be3459aa79379a1.zip
An e17 module displaying the current weather conditions and forecast.
Features are: - choose between simple and detailed view - specify poll time - display degree in Celsius or Fahrenheit - choose the weather station from a menu or via ICAO Code. Author: Matthew Mullins WWW: http://www.enlightenment.org PR: ports/99367 Submitted by: Stanislav Sedov <ssedov@mbsd.msk.ru>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/e17-module-weather/Makefile36
-rw-r--r--x11/e17-module-weather/distinfo3
-rw-r--r--x11/e17-module-weather/files/patch-configure11
-rw-r--r--x11/e17-module-weather/pkg-descr9
-rw-r--r--x11/e17-module-weather/pkg-plist76
6 files changed, 136 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 1bf55800cf1d..640a1f8c5e97 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -38,6 +38,7 @@
SUBDIR += docker
SUBDIR += dxpc
SUBDIR += dynamag
+ SUBDIR += e17-module-weather
SUBDIR += ebuttons
SUBDIR += ecore
SUBDIR += electricsheep
diff --git a/x11/e17-module-weather/Makefile b/x11/e17-module-weather/Makefile
new file mode 100644
index 000000000000..5f9b4237ef1f
--- /dev/null
+++ b/x11/e17-module-weather/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-weather
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weather
+PORTVERSION= 23062006
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 weather module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/e17-module-weather/distinfo b/x11/e17-module-weather/distinfo
new file mode 100644
index 000000000000..286d80bf9239
--- /dev/null
+++ b/x11/e17-module-weather/distinfo
@@ -0,0 +1,3 @@
+MD5 (weather-23062006.tar.bz2) = ea95150b91bd794e1c4d2381e4729a80
+SHA256 (weather-23062006.tar.bz2) = 4847c88494e6f33424911464f91cfe696ae82e70ed512fd900e70a1123ce3ea8
+SIZE (weather-23062006.tar.bz2) = 941161
diff --git a/x11/e17-module-weather/files/patch-configure b/x11/e17-module-weather/files/patch-configure
new file mode 100644
index 000000000000..f4922f2a5aa5
--- /dev/null
+++ b/x11/e17-module-weather/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 17:10:30 2006
++++ configure Fri Jun 23 17:10:42 2006
+@@ -23390,7 +23390,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11/e17-module-weather/pkg-descr b/x11/e17-module-weather/pkg-descr
new file mode 100644
index 000000000000..8f7a06577850
--- /dev/null
+++ b/x11/e17-module-weather/pkg-descr
@@ -0,0 +1,9 @@
+An e17 module displaying the current weather conditions and forecast.
+Features are:
+- choose between simple and detailed view
+- specify poll time
+- display degree in Celsius or Fahrenheit
+- choose the weather station from a menu or via ICAO Code.
+
+Author: Matthew Mullins
+WWW: http://www.enlightenment.org
diff --git a/x11/e17-module-weather/pkg-plist b/x11/e17-module-weather/pkg-plist
new file mode 100644
index 000000000000..8447bc33a25d
--- /dev/null
+++ b/x11/e17-module-weather/pkg-plist
@@ -0,0 +1,76 @@
+lib/enlightenment/modules/weather/VeraBd.ttf
+lib/enlightenment/modules/weather/images/blizzard.png
+lib/enlightenment/modules/weather/images/blowingsnow.png
+lib/enlightenment/modules/weather/images/chancetstorm.png
+lib/enlightenment/modules/weather/images/chancetstormn.png
+lib/enlightenment/modules/weather/images/clear-sky.png
+lib/enlightenment/modules/weather/images/cloud.png
+lib/enlightenment/modules/weather/images/cloudy.png
+lib/enlightenment/modules/weather/images/cloudy_night.png
+lib/enlightenment/modules/weather/images/drizzle.png
+lib/enlightenment/modules/weather/images/fair.png
+lib/enlightenment/modules/weather/images/fdrizzle.png
+lib/enlightenment/modules/weather/images/flurries.png
+lib/enlightenment/modules/weather/images/fog.png
+lib/enlightenment/modules/weather/images/freezingrain.png
+lib/enlightenment/modules/weather/images/hazy.png
+lib/enlightenment/modules/weather/images/heavy-rain.png
+lib/enlightenment/modules/weather/images/ice.png
+lib/enlightenment/modules/weather/images/isolated.t-storm.png
+lib/enlightenment/modules/weather/images/light-rain.png
+lib/enlightenment/modules/weather/images/light-snow.png
+lib/enlightenment/modules/weather/images/luna-ceatza.png
+lib/enlightenment/modules/weather/images/luna-nori.png
+lib/enlightenment/modules/weather/images/mcloudy.png
+lib/enlightenment/modules/weather/images/mcloudyn.png
+lib/enlightenment/modules/weather/images/mcloudynr.png
+lib/enlightenment/modules/weather/images/mcloudyns.png
+lib/enlightenment/modules/weather/images/mcloudyr.png
+lib/enlightenment/modules/weather/images/mcloudys.png
+lib/enlightenment/modules/weather/images/moon-rain.png
+lib/enlightenment/modules/weather/images/moon-snow.png
+lib/enlightenment/modules/weather/images/moon-tstorm.png
+lib/enlightenment/modules/weather/images/moon.png
+lib/enlightenment/modules/weather/images/mostly-cloudy.png
+lib/enlightenment/modules/weather/images/pcloudy.png
+lib/enlightenment/modules/weather/images/pcloudyn.png
+lib/enlightenment/modules/weather/images/pcloudynr.png
+lib/enlightenment/modules/weather/images/pcloudyns.png
+lib/enlightenment/modules/weather/images/pcloudyr.png
+lib/enlightenment/modules/weather/images/pcloudyrn.png
+lib/enlightenment/modules/weather/images/pcloudys.png
+lib/enlightenment/modules/weather/images/rain.png
+lib/enlightenment/modules/weather/images/rainandsnow.png
+lib/enlightenment/modules/weather/images/showers.png
+lib/enlightenment/modules/weather/images/sleet.png
+lib/enlightenment/modules/weather/images/smoke.png
+lib/enlightenment/modules/weather/images/snow.png
+lib/enlightenment/modules/weather/images/snowshowers.png
+lib/enlightenment/modules/weather/images/sun-light-clouds.png
+lib/enlightenment/modules/weather/images/sun.png
+lib/enlightenment/modules/weather/images/suncloud.png
+lib/enlightenment/modules/weather/images/sunny.png
+lib/enlightenment/modules/weather/images/sunnyn.png
+lib/enlightenment/modules/weather/images/sunrain.png
+lib/enlightenment/modules/weather/images/sunsnow.png
+lib/enlightenment/modules/weather/images/t-storm_night.png
+lib/enlightenment/modules/weather/images/thunder.png
+lib/enlightenment/modules/weather/images/tstorm.png
+lib/enlightenment/modules/weather/images/tstormn.png
+lib/enlightenment/modules/weather/images/unknown.png
+lib/enlightenment/modules/weather/images/wind.png
+lib/enlightenment/modules/weather/images/wswarning.png
+lib/enlightenment/modules/weather/images/wswatch.png
+lib/enlightenment/modules/weather/module.a
+lib/enlightenment/modules/weather/module.eap
+lib/enlightenment/modules/weather/module.la
+lib/enlightenment/modules/weather/module.so
+lib/enlightenment/modules/weather/module_icon.png
+lib/enlightenment/modules/weather/vera.ttf
+lib/enlightenment/modules/weather/weather.edc
+lib/enlightenment/modules/weather/weather.edj
+%%NLS%%share/locale/eo/LC_MESSAGES/weather.mo
+%%NLS%%share/locale/it/LC_MESSAGES/weather.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/weather.mo
+@dirrm lib/enlightenment/modules/weather/images
+@dirrm lib/enlightenment/modules/weather