aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-27 09:33:09 +0800
committeranholt <anholt@FreeBSD.org>2003-12-27 09:33:09 +0800
commite3544e3189687b5495bfc0027ba89854f6142b14 (patch)
treec247036e2aca8f48eea98e46566b11bd816cdc8d /x11
parentf166a68f69d5e5aed9cd6986bb293779b76f9e17 (diff)
downloadfreebsd-ports-gnome-e3544e3189687b5495bfc0027ba89854f6142b14.tar.gz
freebsd-ports-gnome-e3544e3189687b5495bfc0027ba89854f6142b14.tar.zst
freebsd-ports-gnome-e3544e3189687b5495bfc0027ba89854f6142b14.zip
New port: Prerelease version of libXfixes from freedesktop.org:
X Fixes extension library Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXfixes/Makefile33
-rw-r--r--x11/libXfixes/distinfo1
-rw-r--r--x11/libXfixes/files/patch-Makefile.in11
-rw-r--r--x11/libXfixes/pkg-descr6
-rw-r--r--x11/libXfixes/pkg-plist6
6 files changed, 58 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 52a0e942e2fc..a61e742c1ea6 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -82,6 +82,7 @@
SUBDIR += libXcursor
SUBDIR += libXdmcp
SUBDIR += libXext
+ SUBDIR += libXfixes
SUBDIR += libXfont
SUBDIR += libXi
SUBDIR += libXrandr
diff --git a/x11/libXfixes/Makefile b/x11/libXfixes/Makefile
new file mode 100644
index 000000000000..e74a2c244c09
--- /dev/null
+++ b/x11/libXfixes/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXfixes
+PORTVERSION= 2.0.0.p2
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Fixes extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/fixesext.pc:${PORTSDIR}/x11/fixesext \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0.0
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXfixes/distinfo b/x11/libXfixes/distinfo
new file mode 100644
index 000000000000..ff992fabc208
--- /dev/null
+++ b/x11/libXfixes/distinfo
@@ -0,0 +1 @@
+MD5 (libXfixes-2.0.0.p2.tar.bz2) = 0a2085fac105a1f166ec2e9a60e6c718
diff --git a/x11/libXfixes/files/patch-Makefile.in b/x11/libXfixes/files/patch-Makefile.in
new file mode 100644
index 000000000000..13fe6d0341b2
--- /dev/null
+++ b/x11/libXfixes/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Nov 13 13:53:00 2003
++++ Makefile.in Thu Nov 13 14:03:32 2003
+@@ -193,7 +193,7 @@
+ libXfixesincludedir = $(includedir)/X11/extensions
+ libXfixesinclude_HEADERS = Xfixes.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xfixes.pc
+
+ EXTRA_DIST = xfixes.pc.in autogen.sh
diff --git a/x11/libXfixes/pkg-descr b/x11/libXfixes/pkg-descr
new file mode 100644
index 000000000000..3dbcfe29afb1
--- /dev/null
+++ b/x11/libXfixes/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Fixes extension library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXfixes/pkg-plist b/x11/libXfixes/pkg-plist
new file mode 100644
index 000000000000..fd7568ce3ace
--- /dev/null
+++ b/x11/libXfixes/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/extensions/Xfixes.h
+lib/libXfixes.a
+lib/libXfixes.la
+lib/libXfixes.so
+lib/libXfixes.so.1
+libdata/pkgconfig/xfixes.pc