aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-10-28 20:24:07 +0800
committerjylefort <jylefort@FreeBSD.org>2005-10-28 20:24:07 +0800
commitf0635c71af028addc3edffa29e9d0360958729c0 (patch)
tree87947e8ee70fb766f353e77d7bfea5ac1b4512e7 /x11
parent97287c737fac6c4cf8b38967b23aac22f8a8a170 (diff)
downloadfreebsd-ports-gnome-f0635c71af028addc3edffa29e9d0360958729c0.tar.gz
freebsd-ports-gnome-f0635c71af028addc3edffa29e9d0360958729c0.tar.zst
freebsd-ports-gnome-f0635c71af028addc3edffa29e9d0360958729c0.zip
Add alltray.
With AllTray you can dock any application with no native tray icon (like Evolution, Thunderbird, terminals) into the system tray. A high-light feature is that a click on the "close" button will minimize back to system tray. It works well with GNOME, KDE, XFCE 4*, Fluxbox* and WindowMaker*. WWW: http://alltray.sourceforge.net/ PR: ports/87545 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/alltray/Makefile43
-rw-r--r--x11/alltray/distinfo2
-rw-r--r--x11/alltray/pkg-descr6
-rw-r--r--x11/alltray/pkg-plist6
5 files changed, 58 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 6bd481621877..373f3ab3017c 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -17,6 +17,7 @@
SUBDIR += XFree86-aoutlibs
SUBDIR += XFree86-contrib
SUBDIR += accessx
+ SUBDIR += alltray
SUBDIR += apwal
SUBDIR += aterm
SUBDIR += bbappconf
diff --git a/x11/alltray/Makefile b/x11/alltray/Makefile
new file mode 100644
index 000000000000..6394a483c5f3
--- /dev/null
+++ b/x11/alltray/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: alltray
+# Date created: 2005-10-15
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alltray
+PORTVERSION= 0.62
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= alltray
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Dock any application with no native tray icon
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" LDFLAGS="-L${X11BASE}/lib"
+USE_GCC= 3.4+
+
+MAN1= alltray.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/lib/Makefile.in
+ @${REINPLACE_CMD} -e 's|-L/usr/X11R6/lib||' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|/etc/gconf|${X11BASE}/etc/gconf|; \
+ /THEME_DIR1/ s|/usr/share/|${X11BASE}/share/gnome/themes/|' \
+ ${WRKSRC}/src/gnome_theme.c
+ @${REINPLACE_CMD} -e 's|liballtray\.so\.0\.0\.0|liballtray.so.0|; \
+ s|/usr/lib|${PREFIX}/lib|' ${WRKSRC}/src/child.c
+
+patch-autotools:
+ @for file in ${LIBTOOLFILES}; do \
+ ${REINPLACE_CMD} -e \
+ '/^ltmain=/ s|$$ac_aux_dir/ltmain\.sh|${LTMAIN}|g' \
+ ${PATCH_WRKSRC}/$$file; \
+ done
+
+.include <bsd.port.mk>
diff --git a/x11/alltray/distinfo b/x11/alltray/distinfo
new file mode 100644
index 000000000000..feb93c1ac574
--- /dev/null
+++ b/x11/alltray/distinfo
@@ -0,0 +1,2 @@
+MD5 (alltray-0.62.tar.gz) = f063900b552831376a59cf7cd313c252
+SIZE (alltray-0.62.tar.gz) = 372087
diff --git a/x11/alltray/pkg-descr b/x11/alltray/pkg-descr
new file mode 100644
index 000000000000..5acfcccc1e59
--- /dev/null
+++ b/x11/alltray/pkg-descr
@@ -0,0 +1,6 @@
+With AllTray you can dock any application with no native tray icon (like
+Evolution, Thunderbird, terminals) into the system tray. A high-light feature
+is that a click on the "close" button will minimize back to system tray. It
+works well with GNOME, KDE, XFCE 4*, Fluxbox* and WindowMaker*.
+
+WWW: http://alltray.sourceforge.net/
diff --git a/x11/alltray/pkg-plist b/x11/alltray/pkg-plist
new file mode 100644
index 000000000000..66a57580bb93
--- /dev/null
+++ b/x11/alltray/pkg-plist
@@ -0,0 +1,6 @@
+bin/alltray
+lib/liballtray.so
+lib/liballtray.so.0
+share/applications/alltray.desktop
+share/pixmaps/alltray.png
+@unexec rmdir %D/share/applications 2>/dev/null || true