aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-11-20 17:51:12 +0800
committerpav <pav@FreeBSD.org>2003-11-20 17:51:12 +0800
commit84697ce72116160762a5bcaf3b89de87e68c6ef9 (patch)
tree706b9da58ab2dfb434cddef3b711d147346c4ba3 /x11
parent0ee9e372caa3a54056801dfee911c616bab98b75 (diff)
downloadfreebsd-ports-gnome-84697ce72116160762a5bcaf3b89de87e68c6ef9.tar.gz
freebsd-ports-gnome-84697ce72116160762a5bcaf3b89de87e68c6ef9.tar.zst
freebsd-ports-gnome-84697ce72116160762a5bcaf3b89de87e68c6ef9.zip
- Fix build on 5.x
PR: ports/58346 Submitted by: Samy Al Bahra <samy@kerneled.com> Approved by: jim (maintainer) Approved by: adamw (mentor)
Diffstat (limited to 'x11')
-rw-r--r--x11/gyroscope/Makefile8
-rw-r--r--x11/gyroscope/files/patch-gtkcolorsel.c15
2 files changed, 16 insertions, 7 deletions
diff --git a/x11/gyroscope/Makefile b/x11/gyroscope/Makefile
index c6319e9619b9..afa3e614ba10 100644
--- a/x11/gyroscope/Makefile
+++ b/x11/gyroscope/Makefile
@@ -20,10 +20,4 @@ USE_GNOME= gtk12
ALL_TARGET= # empty
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/gyroscope/files/patch-gtkcolorsel.c b/x11/gyroscope/files/patch-gtkcolorsel.c
new file mode 100644
index 000000000000..d90da47c8b9e
--- /dev/null
+++ b/x11/gyroscope/files/patch-gtkcolorsel.c
@@ -0,0 +1,15 @@
+--- gtkcolorsel.c.orig Tue Oct 21 22:18:28 2003
++++ gtkcolorsel.c Tue Oct 21 22:18:28 2003
+@@ -320,9 +320,9 @@
+ gtk_container_add (GTK_CONTAINER (about_window), vbox);
+ gtk_widget_show (vbox);
+
+- label = gtk_label_new ("\nGyrosCoPe HTML colour picker\nVersion 1.0\n30th January, 1999
+- \n http://www.millar.u-net.com/gyroscope.html \n
+- neil@millar.u-net.com\n");
++ label = gtk_label_new ("\nGyrosCoPe HTML colour picker\nVersion 1.0\n30th January, 1999\n"\
++" \n http://www.millar.u-net.com/gyroscope.html \n"\
++" neil@millar.u-net.com\n");
+ gtk_box_pack_start (GTK_BOX (vbox), label, TRUE, TRUE, 0);
+ gtk_widget_show (label);
+