aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-08-09 15:55:22 +0800
committermarcus <marcus@FreeBSD.org>2008-08-09 15:55:22 +0800
commit2e220b922f24c9758ac7dd768f5fa3b177f8ccca (patch)
treec58804bd90b7e02dc34e6b8bf30b4be1bcc63412 /x11
parent700a38030ea847705c9f8f7c942c860d9e34cd0c (diff)
downloadfreebsd-ports-gnome-2e220b922f24c9758ac7dd768f5fa3b177f8ccca.tar.gz
freebsd-ports-gnome-2e220b922f24c9758ac7dd768f5fa3b177f8ccca.tar.zst
freebsd-ports-gnome-2e220b922f24c9758ac7dd768f5fa3b177f8ccca.zip
Enable PAM support by default, and depend on pam_helper to provide the
authentication services.
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-screensaver/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index a8b29b5c58a7..eeae47840a69 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnome-screensaver
PORTVERSION= 2.22.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -42,19 +42,15 @@ SCREENSAVER_DIR= share/applications/screensavers
XSCREENSAVER_EXCLUDE= "(popsquares.xml)"
-OPTIONS= PAM "Pluggable Authentication Module support (broken!)" off \
- KEYRING "Enable GnomeKeyring integration (needs PAM)" off
+OPTIONS= PAM "Pluggable Authentication Module support" on \
+ KEYRING "Enable GnomeKeyring integration (needs PAM)" on
.include <bsd.port.pre.mk>
.if defined(WITH_PAM)
-# Currently semi-broken: http://bugzilla.gnome.org/show_bug.cgi?id=370847
-# Our default pam_unix will not be able to authenticate
-# Define GNOME_SCREENSAVER_WITH_BROKEN_PAM only if you know what you are doing.
-.if !defined(GNOME_SCREENSAVER_WITH_BROKEN_PAM)
-IGNORE= PAM support is partially broken. Please read Makefile
-.endif
-CONFIGURE_ARGS+= --enable-pam
+RUN_DEPENDS+= pam_helper:${PORTSDIR}/security/pam_helper
+CONFIGURE_ARGS+= --enable-authentication-scheme=helper \
+ --with-passwd-helper=${LOCALBASE}/bin/pam_helper
PLIST_SUB+= PAM=""
.else
CONFIGURE_ARGS+= --disable-pam