aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /x11
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'x11')
-rw-r--r--x11/arandr/Makefile6
-rw-r--r--x11/gnome-desktop/Makefile2
-rw-r--r--x11/gnome-shell/Makefile4
-rw-r--r--x11/guake/Makefile16
-rw-r--r--x11/ooxcb/Makefile2
-rw-r--r--x11/py-pyvirtualdisplay/Makefile10
-rw-r--r--x11/py-qt4-opengl/Makefile1
-rw-r--r--x11/py-qt5-opengl/Makefile1
-rw-r--r--x11/terminator/Makefile6
-rw-r--r--x11/workrave/Makefile2
-rw-r--r--x11/xpra/Makefile39
-rw-r--r--x11/xpyb/Makefile3
12 files changed, 47 insertions, 45 deletions
diff --git a/x11/arandr/Makefile b/x11/arandr/Makefile
index 05aa31962be2..7a4e4c1f504a 100644
--- a/x11/arandr/Makefile
+++ b/x11/arandr/Makefile
@@ -12,14 +12,14 @@ COMMENT= Another XRandR GUI
LICENSE= GPLv3
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0.6:textproc/py-docutils
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0.6:textproc/py-docutils@${FLAVOR}
RUN_DEPENDS= xrandr>0:x11/xrandr \
- ${PYTHON_PKGNAMEPREFIX}gtk2>0:x11-toolkits/py-gtk2
+ ${PYTHON_PKGNAMEPREFIX}gtk2>0:x11-toolkits/py-gtk2@${FLAVOR}
OPTIONS_DEFINE= DOCS
USE_PYTHON= distutils
-USES+= gettext desktop-file-utils python
+USES+= gettext desktop-file-utils python:2.7
PORTDOCS= ChangeLog NEWS README TODO
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index 4ac8b2d301c4..f317b2e72289 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -31,7 +31,7 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
xkeyboard-config>=0:x11/xkeyboard-config \
libxkbfile>=0:x11/libxkbfile
-USES+= bison gettext gmake gnome libtool localbase pathfix pkgconfig python:3
+USES+= bison gettext gmake gnome libtool localbase pathfix pkgconfig python:3.4+
USE_GNOME= gtk30 intlhack introspection:build referencehack
USE_XORG= x11 xrandr xext
USE_LDCONFIG= yes
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
index 961bed5b5b26..10c0fa1d8bba 100644
--- a/x11/gnome-shell/Makefile
+++ b/x11/gnome-shell/Makefile
@@ -41,7 +41,7 @@ LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libcogl.so:graphics/cogl \
libclutter-1.0.so:graphics/clutter \
libgjs.so:lang/gjs
-RUN_DEPENDS= py*-dbus>=0:devel/py-dbus \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
nss>=0:security/nss \
gnome-control-center:sysutils/gnome-control-center \
ca_root_nss>=0:security/ca_root_nss \
@@ -50,7 +50,7 @@ RUN_DEPENDS= py*-dbus>=0:devel/py-dbus \
PORTSCOUT= limitw:1,even
USES= compiler:c11 cpe gettext gmake gnome libtool localbase \
- pathfix pkgconfig sqlite tar:xz webplugin:native
+ pathfix pkgconfig python:3.4+ sqlite tar:xz webplugin:native
USE_GNOME= cairo evolutiondataserver3 gdkpixbuf2 gtk30 intltool \
introspection libxml2
USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 504c0f15f8d6..77a5a48f3a1f 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -12,15 +12,15 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gnome-common>=3.14.0:devel/gnome-common \
- ${PYTHON_PKGNAMEPREFIX}dbus>=0.84.0:devel/py-dbus \
- ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1_9:devel/py-notify \
- ${PYTHON_PKGNAMEPREFIX}vte>=0.26.2_1:x11-toolkits/py-vte \
- ${PYTHON_PKGNAMEPREFIX}xdg>=0.19:devel/py-xdg
+ ${PYTHON_PKGNAMEPREFIX}dbus>=0.84.0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1_9:devel/py-notify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vte>=0.26.2_1:x11-toolkits/py-vte@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0.19:devel/py-xdg@${PY_FLAVOR}
RUN_DEPENDS= keybinder>=0.3.0:x11/keybinder \
- ${PYTHON_PKGNAMEPREFIX}dbus>=0.84.0:devel/py-dbus \
- ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1_9:devel/py-notify \
- ${PYTHON_PKGNAMEPREFIX}vte>=0.26.2_1:x11-toolkits/py-vte \
- ${PYTHON_PKGNAMEPREFIX}xdg>=0.19:devel/py-xdg
+ ${PYTHON_PKGNAMEPREFIX}dbus>=0.84.0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}notify>=0.1.1_9:devel/py-notify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vte>=0.26.2_1:x11-toolkits/py-vte@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0.19:devel/py-xdg@${PY_FLAVOR}
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11/ooxcb/Makefile b/x11/ooxcb/Makefile
index 181f8f12c502..ab3c8707f045 100644
--- a/x11/ooxcb/Makefile
+++ b/x11/ooxcb/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
NO_ARCH= yes
-USES= python
+USES= python:2.7
USE_PYTHON= distutils autoplist
USE_XORG= xcb
diff --git a/x11/py-pyvirtualdisplay/Makefile b/x11/py-pyvirtualdisplay/Makefile
index 55b846ba07d3..fbaae742dfd3 100644
--- a/x11/py-pyvirtualdisplay/Makefile
+++ b/x11/py-pyvirtualdisplay/Makefile
@@ -15,11 +15,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= xorg-vfbserver>0:x11-servers/xorg-vfbserver \
xauth>0:x11/xauth \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}paver>0:devel/py-paver \
- ${PYTHON_PKGNAMEPREFIX}cog>=2.3:devel/py-cog \
- ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx \
- ${PYTHON_PKGNAMEPREFIX}easyprocess>0:devel/py-easyprocess
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paver>0:devel/py-paver@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cog>=2.3:devel/py-cog@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}easyprocess>0:devel/py-easyprocess@${FLAVOR}
NO_ARCH= yes
USE_PYTHON= autoplist distutils
diff --git a/x11/py-qt4-opengl/Makefile b/x11/py-qt4-opengl/Makefile
index 8d4ccbb96ee7..c265eec4d1cb 100644
--- a/x11/py-qt4-opengl/Makefile
+++ b/x11/py-qt4-opengl/Makefile
@@ -15,6 +15,7 @@ PYQT_DIST= yes
USES= python pyqt:4
USE_GL= gl
USE_PYQT= sip_build core_run gui_run
+USE_PYTHON= flavors
USE_QT4= corelib gui opengl moc_build qmake_build
OPTIONS_DEFINE= API DEBUG
diff --git a/x11/py-qt5-opengl/Makefile b/x11/py-qt5-opengl/Makefile
index f9de6b0d2401..b89bfed3c973 100644
--- a/x11/py-qt5-opengl/Makefile
+++ b/x11/py-qt5-opengl/Makefile
@@ -13,6 +13,7 @@ PYQT_DIST= yes
USES= python pyqt:5
USE_GL= gl
USE_PYQT= sip_build core_run gui_run widgets_run
+USE_PYTHON= flavors
USE_QT5= core gui opengl widgets qmake_build
OPTIONS_DEFINE= API DEBUG
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index dbd31fb0b572..0db199a1a705 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -12,11 +12,11 @@ COMMENT= Multiple GNOME terminals in one window
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0:devel/py-notify \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0:devel/py-notify@${FLAVOR} \
${PYTHON_SITELIBDIR}/keybinder/_keybinder.so:x11/keybinder \
- ${PYTHON_PKGNAMEPREFIX}vte>=0:x11-toolkits/py-vte
+ ${PYTHON_PKGNAMEPREFIX}vte>=0:x11-toolkits/py-vte@${FLAVOR}
-USES= python
+USES= python:2.7
USE_GNOME= pygtk2 intltool
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= Terminator
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 06175b96d15f..b837f496b6d2 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -42,7 +42,7 @@ OPTIONS_SUB= yes
DISTRIBUTION_DESC= Build with networking support
-DBUS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>0:devel/py-cheetah
+DBUS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>0:devel/py-cheetah@${PY_FLAVOR}
DBUS_CONFIGURE_ENABLE= dbus
DBUS_USES= python:2.7
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index 13b90719732a..e2ecfeb31bc7 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -12,35 +12,34 @@ COMMENT= Xpra gives you persistent remote applications for X
LICENSE= GPLv2
-BUILD_DEPENDS= cython:lang/cython \
- ${PYTHON_PKGNAMEPREFIX}gtk2>2:x11-toolkits/py-gtk2 \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>2:x11-toolkits/py-gtk2@${FLAVOR} \
${PYNUMPY}
LIB_DEPENDS= libturbojpeg.so:graphics/libjpeg-turbo \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lz4>=0.7.0_1:archivers/py-lz4 \
- ${PYTHON_PKGNAMEPREFIX}rencode>1:converters/py-rencode \
- ${PYTHON_PKGNAMEPREFIX}dbus>1:devel/py-dbus \
- ${PYTHON_PKGNAMEPREFIX}pyinotify>0:devel/py-pyinotify \
- ${PYTHON_PKGNAMEPREFIX}xxhash>0:devel/py-xxhash \
- ${PYTHON_PKGNAMEPREFIX}pillow>=3.0:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=3.1.0:graphics/py-PyOpenGL \
- ${PYTHON_PKGNAMEPREFIX}PyOpenGL-accelerate>=3.1.0:graphics/py-PyOpenGL-accelerate \
- ${PYTHON_PKGNAMEPREFIX}netifaces>0:net/py-netifaces \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lz4>=0.7.0_1:archivers/py-lz4@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rencode>1:converters/py-rencode@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbus>1:devel/py-dbus@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyinotify>0:devel/py-pyinotify@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xxhash>0:devel/py-xxhash@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=3.0:graphics/py-pillow@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=3.1.0:graphics/py-PyOpenGL@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}PyOpenGL-accelerate>=3.1.0:graphics/py-PyOpenGL-accelerate@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netifaces>0:net/py-netifaces@${FLAVOR} \
ssh-askpass:security/openssh-askpass \
- ${PYTHON_PKGNAMEPREFIX}cryptography>1:security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>1:security/py-cryptography@${FLAVOR} \
setxkbmap:x11/setxkbmap \
xauth:x11/xauth \
xkbcomp:x11/xkbcomp \
${LOCALBASE}/share/X11/xkb/rules/base:x11/xkeyboard-config \
Xvfb:x11-servers/xorg-vfbserver \
- ${PYTHON_PKGNAMEPREFIX}gtk2>2:x11-toolkits/py-gtk2 \
- ${PYTHON_PKGNAMEPREFIX}gtkglext>1:x11-toolkits/py-gtkglext \
+ ${PYTHON_PKGNAMEPREFIX}gtk2>2:x11-toolkits/py-gtk2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gtkglext>1:x11-toolkits/py-gtkglext@${FLAVOR} \
${PYNUMPY}
USES= desktop-file-utils fortran gettext-runtime pkgconfig python:2 shared-mime-info shebangfix tar:xz
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
-USE_PYTHON= distutils
+USE_PYTHON= distutils cython
USE_XORG= x11 xcomposite xdamage xext xfixes xkbfile xrandr xtst
PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHON_VER=${PYTHON_VER}
SHEBANG_FILES= cups/xpraforwarder
@@ -61,14 +60,14 @@ WEBCAM_DESC= Enable webcam forwarding (client only)
X264_DESC= Enable X264 encoder
X265_DESC= Enable X265 encoder (slow)
-AVAHI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}avahi>0:net/py-avahi
+AVAHI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}avahi>0:net/py-avahi@${FLAVOR}
AVAHI_VARS= XPRA_OPTIONS+=mdns
AVCODEC_VARS= XPRA_OPTIONS+=dec_avcodec2
-CUPS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycups>1:print/py-pycups
+CUPS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycups>1:print/py-pycups@${FLAVOR}
CUPS_VARS= XPRA_OPTIONS+=printing
FFMPEG_VARS= XPRA_OPTIONS+=enc_ffmpeg
-GSTREAMER_BUILD_DEPENDS=${PYTHON_PKGNAMEPREFIX}gstreamer1>1:multimedia/py-gstreamer1
-GSTREAMER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gstreamer1>1:multimedia/py-gstreamer1
+GSTREAMER_BUILD_DEPENDS=${PYTHON_PKGNAMEPREFIX}gstreamer1>1:multimedia/py-gstreamer1@${FLAVOR}
+GSTREAMER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gstreamer1>1:multimedia/py-gstreamer1@${FLAVOR}
GSTREAMER_USE= GSTREAMER1=flac,lame,mpg123,ogg,opus,vorbis,wavpack
GSTREAMER_VARS= XPRA_OPTIONS+=sound
HTML5_VARS= XPRA_OPTIONS+=html5
@@ -78,7 +77,7 @@ SWSCALE_LIB_DEPENDS= libswscale.so:multimedia/ffmpeg
SWSCALE_VARS= XPRA_OPTIONS+=csc_swscale
VPX_LIB_DEPENDS= libvpx.so:multimedia/libvpx
VPX_VARS= XPRA_OPTIONS+=vpx
-WEBCAM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opencv>2:graphics/py-opencv
+WEBCAM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opencv>2:graphics/py-opencv@${FLAVOR}
WEBCAM_VARS= XPRA_OPTIONS+=webcam
X264_LIB_DEPENDS= libx264.so:multimedia/libx264
X264_VARS= XPRA_OPTIONS+=enc_x264
diff --git a/x11/xpyb/Makefile b/x11/xpyb/Makefile
index 655391aeed46..7435b06106e1 100644
--- a/x11/xpyb/Makefile
+++ b/x11/xpyb/Makefile
@@ -14,7 +14,8 @@ COMMENT= Python bindings to access X Window System protocol via libxcb
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-proto.pc:x11/xcb-proto \
xcb-proto>=1.7.1:x11/xcb-proto
-USES= libtool pathfix pkgconfig python tar:bzip2
+USES= libtool pathfix pkgconfig python:2.7 tar:bzip2
+USE_PYTHON= flavors
USE_XORG= xcb
PORTDOCS= README COPYING INSTALL NEWS XcbPythonBinding.txt