aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-01-09 01:41:58 +0800
committertcberner <tcberner@FreeBSD.org>2018-01-09 01:41:58 +0800
commit53326993c6a553b12811d2f4704527b9cd0b4c4a (patch)
tree3a24d7527210d14d9889ae753d7c226e90b01c73 /x11
parent795975746522a3b71f66e1d1ce1ec7bac9742857 (diff)
downloadfreebsd-ports-gnome-53326993c6a553b12811d2f4704527b9cd0b4c4a.tar.gz
freebsd-ports-gnome-53326993c6a553b12811d2f4704527b9cd0b4c4a.tar.zst
freebsd-ports-gnome-53326993c6a553b12811d2f4704527b9cd0b4c4a.zip
x11/kdelibs4, fix build on i386 with clang6
The previous fixes in r458314 were not enough for i386. Backport fix from x11/kf5-kdelibs4support. PR: 224945
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/kdelibs4/files/patch-git_071caf36
2 files changed, 37 insertions, 1 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 605a58131a3c..70b923f1e4aa 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_KDELIBS_VERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11 kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/x11/kdelibs4/files/patch-git_071caf b/x11/kdelibs4/files/patch-git_071caf
new file mode 100644
index 000000000000..60f2a88ee1e2
--- /dev/null
+++ b/x11/kdelibs4/files/patch-git_071caf
@@ -0,0 +1,36 @@
+Backport of:
+
+From 071cafe32212ced460c64ed56111387be975d1ae Mon Sep 17 00:00:00 2001
+From: "Tobias C. Berner" <tcberner@gmail.com>
+Date: Sun, 20 Nov 2016 12:16:30 +0100
+Subject: [PATCH] Fix build on FreeBSD-i386.
+
+/wrkdirs/usr/ports/x11/kf5-kdelibs4support/work/kdelibs4support-5.27.0/src/kdeui/kpixmapcache.cpp:1161:88:
+ error: non-constant-expression cannot be narrowed from type 'quint32' (aka 'unsigned int')
+ to 'time_t' (aka 'int') in initializer list [-Wc++11-narrowing]
+ KPixmapCacheIndexHeader indexHeader = { {0}, KPIXMAPCACHE_VERSION, 0, d->mCacheId, d->mTimestamp };
+ ^~~~~~~~~~~~~
+/wrkdirs/usr/ports/x11/kf5-kdelibs4support/work/kdelibs4support-5.27.0/src/kdeui/kpixmapcache.cpp:1161:88:
+ note: override this message by inserting an explicit cast
+ KPixmapCacheIndexHeader indexHeader = { {0}, KPIXMAPCACHE_VERSION, 0, d->mCacheId, d->mTimestamp };
+ ^~~~~~~~~~~~~
+ static_cast<time_t>( )
+
+REVIEW: 129441
+---
+ kdeui/util/kpixmapcache.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/kdeui/kpixmapcache.cpp b/src/kdeui/kpixmapcache.cpp
+index 2d175717..b7a688ba 100644
+--- kdeui/util/kpixmapcache.cpp
++++ kdeui/util/kpixmapcache.cpp
+@@ -1158,7 +1158,7 @@ bool KPixmapCache::recreateCacheFiles()
+
+ // We can't know the full size until custom headers written.
+ // mmapFiles() will take care of correcting the size.
+- KPixmapCacheIndexHeader indexHeader = { {0}, KPIXMAPCACHE_VERSION, 0, d->mCacheId, d->mTimestamp };
++ KPixmapCacheIndexHeader indexHeader = { {static_cast<time_t>(0)}, KPIXMAPCACHE_VERSION, 0, d->mCacheId, static_cast<time_t>(d->mTimestamp) };
+ memcpy(indexHeader.magic, KPC_MAGIC, sizeof(indexHeader.magic));
+
+ indexfile.write(reinterpret_cast<char *>(&indexHeader), sizeof indexHeader);