aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-07-24 03:53:11 +0800
committerrakuco <rakuco@FreeBSD.org>2014-07-24 03:53:11 +0800
commit687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b (patch)
tree4e541e979a7f5bac477f1b27f24bd820268cd256 /x11
parentbc7c6637ec10444b00d1f6e95659ee1c5aa7d610 (diff)
downloadfreebsd-ports-gnome-687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b.tar.gz
freebsd-ports-gnome-687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b.tar.zst
freebsd-ports-gnome-687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b.zip
Update PyQt to 4.11.1, QScintilla to 2.8.3 and SIP to 4.16.2.
... And bump PORTREVISION on ports that depend on devel/qscintilla2 due to the shlib version change. This is brought to you by the KDE on FreeBSD team. Besides updating to newer upstream releases, this commit also contains a lot of under-the-hood changes to the PyQt/QScintilla/SIP ports. Their Makefiles had accumulated a lot of cruft over time, so it was time for some summer cleaning: - General, belated changes: * Use OPTIONS helpers wherever possible, stop including <bsd.port.options.mk> when not necessary, stop checking for ${PORT_OPTIONS:MDOCS} and ${PORT_OPTIONS:MEXAMPLES} when not necessary, add options such as DOCS and/or DEBUG where they were only checked for. - QScintilla ports: * Drop the API option from py-qt4-qscintilla2. It had been broken ever since staging support was added, and its existence does not make much sense: QScintilla is a hard dependency regardless of the state of this option anyway, they all come from the same tarball and the configuration script assumes the .api file will always be installed. - PyQt ports: * The configure.py patch shared by all PyQt ports has been trimmed down to the minimum. Changes for Qt3 compatibility or for things that are just not needed anymore have been removed. * Several post-configure targets in the PyQt ports have been removed, as they had no effect on the way the ports were built whatsoever. * In some cases, instead of calling Python's py_compile.py on `ls *.py */*.py */*/*.py` to generate .pyc and .pyo files, we just call compileall.py, which is made for this kind of task. * The patch + sed hack to build py-qt4-dbussupport has been replaced by only extracting the dbus/ directory for that port and excluding it from all others. * Move the bulk of the code in all Makefiles to bsd.pyqt.mk, like the non-Python Qt ports do with bsd.qt.mk and the QT_DIST variable. A large portion of all PyQt Makefiles were very similar and contained a lot of boilerplate code that can be shared among all of them since they all come from the same tarball. bsd.pyqt.mk now has a PYQT4_DIST variable that, when set, automatically sets several common variables and the do-configure target for a port. This allows us to considerably reduce the size of all the py-qt4-* Makefiles. * To make the above possible and also to allow us to use as many OPTIONS helpers as possible, the ARGS variable is now called CONFIGURE_ARGS. That's what it was used for anyway. PR: 191990
Diffstat (limited to 'x11')
-rw-r--r--x11/leechcraft/Makefile1
-rw-r--r--x11/py-qt4-opengl/Makefile57
-rw-r--r--x11/py-qt4-opengl/pkg-plist1
3 files changed, 10 insertions, 49 deletions
diff --git a/x11/leechcraft/Makefile b/x11/leechcraft/Makefile
index b6aa97c96c72..538c182e5c04 100644
--- a/x11/leechcraft/Makefile
+++ b/x11/leechcraft/Makefile
@@ -3,6 +3,7 @@
PORTNAME= leechcraft
PORTVERSION= 0.6.65
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://dist.leechcraft.org/LeechCraft/0.6.70/
DISTNAME= ${PORTNAME}-${PORTVERSION}
diff --git a/x11/py-qt4-opengl/Makefile b/x11/py-qt4-opengl/Makefile
index 58999b0d6403..a7ee4e56fc22 100644
--- a/x11/py-qt4-opengl/Makefile
+++ b/x11/py-qt4-opengl/Makefile
@@ -2,12 +2,8 @@
# $FreeBSD$
PORTNAME= opengl
-PORTVERSION= ${PYQT4_VERSION}
PORTEPOCH= 1
CATEGORIES= x11 devel python
-MASTER_SITES= ${MASTER_SITES_PYQT4}
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
-DISTNAME= ${PYQT4_DISTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtOpenGL module
@@ -15,54 +11,19 @@ COMMENT= Python bindings for the Qt4 toolkit, QtOpenGL module
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui
-DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
-HAS_CONFIGURE= yes
-USE_PYTHON= yes
+CONFIGURE_ARGS= --enable QtOpenGL
+PYQT4_DIST= yes
USE_QT4= moc_build opengl qmake_build
-OPTIONS_DEFINE= API
+OPTIONS_DEFINE= API DEBUG
OPTIONS_DEFAULT=API
-API_DESC= Install QtOpenGL API for QScintilla2
+OPTIONS_SUB= yes
-PATCHDIR= ${.CURDIR}/../../devel/py-qt4-core/files
-OPTIONSFILE?= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
-SIPDIR= ${PREFIX}/share/py-sip
-QSCIDIR= ${PREFIX}/share/qt4/qsci
-ARGS= -b ${PREFIX}/bin \
- -d ${PYTHONPREFIX_SITELIBDIR} \
- -p ${PREFIX}/${QT_PLUGINDIR_REL} \
- -q ${QMAKE} \
- --confirm-license \
- --sipdir ${SIPDIR} \
- --enable QtOpenGL \
- CC="${CC}" CXX="${CXX}" LINK="${CXX}" LINK_SHLIB="${CXX}" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+API_DESC= Install QtOpenGL API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
+DEBUG_CONFIGURE_ON= --debug --trace
.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MAPI)
-ARGS+= --no-qsci-api
-PLIST_SUB+= API="@comment "
-.else
-LIB_DEPENDS+= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
-ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
-PLIST_SUB+= API=""
-.endif
-
-.if defined(WITH_DEBUG)
-ARGS+= --debug --trace
-.endif
-
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
- ${PYTHON_CMD} configure.py ${ARGS}
-
-post-configure:
- ${REINPLACE_CMD} -e 's|^CC.*|CC = ${CC}|' \
- -e 's|^CXX.*|CXX = ${CXX}|' \
- -e 's|^LINK.*|LINK = ${CXX}|' \
- -e 's|^CFLAGS|CXXFLAGS|' \
- ${WRKSRC}/qpy/QtOpenGL/Makefile
-
.include <bsd.port.mk>
diff --git a/x11/py-qt4-opengl/pkg-plist b/x11/py-qt4-opengl/pkg-plist
index daece4e4972a..1da4a58318b2 100644
--- a/x11/py-qt4-opengl/pkg-plist
+++ b/x11/py-qt4-opengl/pkg-plist
@@ -1,6 +1,5 @@
%%PYTHON_SITELIBDIR%%/PyQt4/QtOpenGL.so
share/py-sip/QtOpenGL/QtOpenGLmod.sip
-share/py-sip/QtOpenGL/opengl_types.sip
share/py-sip/QtOpenGL/qgl.sip
share/py-sip/QtOpenGL/qglbuffer.sip
share/py-sip/QtOpenGL/qglcolormap.sip